Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vfs(9) [freebsd man page]

VFS(9)							   BSD Kernel Developer's Manual						    VFS(9)

NAME
VFS -- kernel interface to file systems DESCRIPTION
Calls used to set or query file systems for settings or information. File systems that do not implement a VFS operation should use the appropriate vfs_std function from src/sys/kern/vfs_default.c rather than implementing empty functions or casting to eopnotsupp. SEE ALSO
VFS_CHECKEXP(9), VFS_FHTOVP(9), VFS_INIT(9), VFS_MOUNT(9), VFS_QUOTACTL(9), VFS_SET(9), VFS_STATFS(9), VFS_SYNC(9), VFS_UNMOUNT(9), VFS_VGET(9), vnode(9), VOP_VPTOFH(9) AUTHORS
This manual page was written by Doug Rabson. BSD
February 9, 2010 BSD

Check Out this Related Man Page

VFS_FHTOVP(9)						   BSD Kernel Developer's Manual					     VFS_FHTOVP(9)

NAME
VFS_FHTOVP -- turn an NFS filehandle into a vnode SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_FHTOVP(struct mount *mp, struct fid *fhp, struct vnode **vpp); DESCRIPTION
The VFS_FHTOVP() macro is used by the NFS server to turn an NFS filehandle into a vnode. The arguments it expects are: mp The file system. fhp The filehandle to convert. vpp Return parameter for the new locked vnode. The contents of the filehandle are defined by the file system and are not examined by any other part of the system. It should contain enough information to uniquely identify a file within the file system as well as noticing when a file has been removed and the file system resources have been reused for a new file. For instance, UFS file system stores the inode number and inode generation counter in its filehandle. A call to VFS_FHTOVP() should generally be preceded by a call to VFS_CHECKEXP(9) to check if the file is accessible to the client. RETURN VALUES
The locked vnode for the file will be returned in *vpp. SEE ALSO
VFS(9), VFS_CHECKEXP(9), VOP_VPTOFH(9), vnode(9) AUTHORS
This manual page was written by Doug Rabson. BSD
January 4, 2010 BSD
Man Page

5 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Mounting Dir's to VFS table

Does anyone know a way to mount new directories into the VFS table without having to type them in? Thanks in advance! - BC (1 Reply)
Discussion started by: wcostigan
1 Replies

2. UNIX for Dummies Questions & Answers

kernel panic

hello :-) I have one problem with my LiLO... I installed PLD Linux on my computer but when it boots, the last thing I can see is: request_module Root fs not mounted VFS: Cannot open root device 03:01 Kernel panic: VFS: unable to mount root fs on 03:01 and the system stops :-( what... (1 Reply)
Discussion started by: pgas
1 Replies

3. Programming

A system hang issue in porting an old fs to kernel 2.6.32.*

Hi, I ported a file system from Kernel version 2.6.18.* to 2.6.32.46 as VFS implementation has changed and prepare_write/commit_write are replaced by write_begin/write_end pairs. Implemented the feature by writing a wrapper for write_begin and write_end and calling original functions for... (0 Replies)
Discussion started by: Praveen_218
0 Replies

4. Red Hat

VFS (virtual file system)

hlow all, i want to know how we do insert big file in VFS and how we do to call that file again can anyone explain about that thx before (0 Replies)
Discussion started by: zvtral
0 Replies

5. UNIX for Dummies Questions & Answers

Minix 3.2.1 MFS/VFS/PFS?

Hi. I'm starting to use minix and the version I'm using is 3.2.1. I didn't understand why in this version there are MFS/VFS/PFS file systems and in the other versions there is only FS. I'm trying to modify the file system but I don't know where should I modify. Does anyone know why are there... (0 Replies)
Discussion started by: ReonarudoB
0 Replies