VM_PAGE_RENAME(9) BSD Kernel Developer's Manual VM_PAGE_RENAME(9)NAME
vm_page_rename -- move a page
SYNOPSIS
#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>
void
vm_page_rename(vm_page_t m, vm_object_t new_object, vm_pindex_t new_pindex);
DESCRIPTION
The vm_page_rename() function removes a page from one object, and adds it to another at the given page index. The page is added to the given
object, and is removed from the object that is currently associated with. If the page is currently on the cache queue it will be deactivated
unless it is wired or unmanaged, in which case the deactivation will fail. The entire page is marked as dirty after the move.
The arguments to vm_page_rename() are:
m The page to move.
new_object The object the page should be inserted into.
new_pindex The page index into new_object at which the new page should be inserted.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD July 17, 2001 BSD
Check Out this Related Man Page
VM_PAGE_INSERT(9) BSD Kernel Developer's Manual VM_PAGE_INSERT(9)NAME
vm_page_insert, vm_page_remove -- add/remove page from an object
SYNOPSIS
#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>
void
vm_page_insert(vm_page_t m, vm_object_t object, vm_pindex_t pindex);
void
vm_page_remove(vm_page_t m);
DESCRIPTION
The vm_page_insert() function adds a page to the given object at the given index. The page is added to both the VM page hash table and to
the object's list of pages, but the hardware page tables are not updated. In the case of a user page, it will be faulted in when it is
accessed. If the page is a kernel page, the caller is expected to handle adding the page to the kernel's pmap.
If PG_WRITEABLE is set in the page's flags, OBJ_WRITEABLE and OBJ_MIGHTBEDIRTY are set in the object's flags.
The vm_page_remove() function removes the given page from its object, and from the VM page hash table. The page must be busy prior to this
call, or the system will panic. The pmap entry for the page is not removed by this function.
The arguments to vm_page_insert() are:
m The page to add to the object.
object The object the page should be added to.
pindex The index into the object the page should be at.
The arguments to vm_page_remove() are:
m The page to remove.
IMPLEMENTATION NOTES
The index of a page in a VM object is the byte index into the same object truncated to a page boundary. For example, if the page size is
4096 bytes, and the address in the object is 81944, the page index is 20.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD July 17, 2001 BSD
Introduction
Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
nwbqBdghh6E
The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning .
Does this mean that it will run on any shell ?
Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Hi everyone,
I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX.
Ok onto business, my questions are-:
Was/Is UNIX ever an open source operating system ?
If UNIX was... (21 Replies)
A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component:
Vue.component("unix-time", {
template: `<div class="time">{{unixtime}}</div>`,
data() {
return {
unixtime: ""
};
},
methods: {
... (1 Reply)
i read here that linux provides no way to determine when a directory was created.
https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it.
That file says
I put the script in that directory and... (3 Replies)
Hello.
I can use any particular (stupid or not) format when using bash date command.
Example :
~> date --date "now" '+%Y-%m-%d %H!%M!%S'
2019-06-03 12!55!33or
~> date --date "now" '+%Y£%m£%d %H¤%M¤%S'
2019£06£03 12¤57¤36
or
~> date --date "now" '+%Y-%m-%d %H-%M-%S'
2019-06-03 12-58-51
... (4 Replies)
Morning All
So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question:
Currently I use Oracle VirtualBox, can... (8 Replies)
I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager.
FreeBSD slices are as follows;
/ on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f.
I hesitate to install Solaris 10... (2 Replies)
I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement?
for i in 1 2 3; do
echo "Ready?"
sleep 2
... (10 Replies)