Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

atalk(4) [netbsd man page]

ATALK(4)						   BSD Kernel Interfaces Manual 						  ATALK(4)

NAME
atalk -- AppleTalk Protocol Family SYNOPSIS
#include <sys/types.h> #include <netatalk/at.h> DESCRIPTION
The AppleTalk Protocol Family provides presentation layer support for the AppleTalk Datagram Delivery Protocol (DDP), using the SOCK_DGRAM socket type. In addition, access to in-kernel AppleTalk routing tables and network interface configurations is provided. The AppleTalk Protocol Suite provides support for five kinds of physical media: LocalTalk (230kbps wire-or'd serial), Ethernet, FDDI, Token Ring, and asynchronous serial connections (using either AppleTalk Remote Access (ARA) or PPP ). Currently, NetBSD's AppleTalk implementation supports Ethernet, FDDI, and Token Ring. AppleTalk packets are encapsulated on the Ethernet using the EtherTalk Link Access Protocol (ELAP). Local network address resolution is han- dled using the AppleTalk Address Resolution Protocol (AARP). Neither of these protocols is exposed to user-mode applications. ADDRESSING
AppleTalk addresses are three byte quantities, stored in network byte order. The include file <netatalk/at.h> defines the AppleTalk address format. Sockets in the AppleTalk protocol family use the following address structure: struct sockaddr_at { uint8_t sat_len; sa_family_t sat_family; uint8_t sat_port; struct at_addr sat_addr; union { struct netrange r_netrange; char r_zero[8]; } sat_range; }; The port of a socket may be set with bind(2). The node for bind(2) must always be ATADDR_ANYNODE: ``this node''. The net must be ATADDR_ANYNET. ATADDR_ANYNET corresponds to the machine's ``primary'' address (the first configured). The port of a socket and the primary address are returned with getsockname(2). PROTOCOLS
The AppleTalk protocol family comprises the DDP datagram delivery protocol, AppleTalk Data Stream Protocol (ADSP), AppleTalk Echo Protocol (AEP), AppleTalk Filing Protocol (AFP), AppleTalk Session Protocol (ASP), AppleTalk Transaction Protocol (ATP), Name Binding Protocol (NBP), Printer Access Protocol (PAP), and Zone Information Protocol (ZIP). DDP is implemented in the kernel as SOCK_DGRAM sockets in the AF_APPLETALK address family. NetBSD implements all other AppleTalk protocols using the Netatalk package. Netatalk implements all functions except for ADSP and an AFP client. AEP, NBP, and ZIP services are provided by the atalkd daemon. ASP and ATP services are provided by a user library. PAP and AFP services are provided by user programs and daemons. SEE ALSO
bind(2), getsockname(2), options(4) Gursharan S. Sidhu, Richard F. Andrews, and Alan B. Oppenheimer, Inside AppleTalk, second edition. BSD
November 14, 1997 BSD

Check Out this Related Man Page

PAP(1)							      General Commands Manual							    PAP(1)

NAME
pap, papstatus - client interface to remote printers using Printer Access Protocol SYNOPSIS
pap [ -c ] [ -e ] [ -p nbpname ] [ -s statusfile ] [ files ] papstatus [ -p nbpname ] DESCRIPTION
pap is used to connect and send files to an AppleTalk connected printer using the Apple Printer Access Protocol (PAP). When pap starts execution, it tries to open a session with the printer using PAP, and then downloads the files to the printer. If no files are given on the command line, pap begins reading from standard input. If no printer is specified on the command line, pap looks for a file called .paprc in the current working directory and reads it to obtain the nbpname of a printer. Blank lines and lines that begin with a `#' are ignored. type and zone default to LaserWriter and the zone of the local host, respectively. Note that pap is designed to be useful as a communication filter for sending lpd(8) spooled print jobs to AppleTalk connected printers. See psf(8) for hints on how to use it this way. OPTIONS
-c Take cuts. Normally pap tells the printer how long it has been waiting. When -c is specified, pap claims to have been waiting for- ever. -e Send any message from the printer to stderr instead of stdout. psf(8) invokes pap with this option. -p nbpname Connect to the printer named nbpname and do not consult the .paprc file to find a printer name. See nbp_name(3) for the syntax of nbpname. -s statusfile Update the file called statusfile to contain the most recent status message from the printer. pap gets the status from the printer when it is waiting for the printer to process input. The statusfile will contain a single line terminated with a newline. This is useful when pap is invoked by psf(8) within lpd's spool directory. FILES
.paprc file that contains printer name SEE ALSO
nbp_name(3), lpd(8), psf(8). netatalk 1.3 3 Jun 1994 PAP(1)
Man Page