Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

spi(4) [netbsd man page]

SPI(4)							   BSD Kernel Interfaces Manual 						    SPI(4)

NAME
spi -- introduction to machine-independent SPI bus support and drivers SYNOPSIS
spi* at mainbus? Other attachments are machine-dependent and will depend on the bus topology of your system. See intro(4) for your system for more informa- tion. DESCRIPTION
NetBSD includes a machine dependent SPI (Serial Peripheral Interface) bus subsystem, and several different machine-independent SPI device drivers. Your system may support additional machine-dependent SPI devices. Consult your system's intro(4) for additional information. SPI is a 4-wire synchronous full-duplex serial bus. Some systems provide support for Microwire, which is Philips' name for a strict subset of SPI, with more rigidly defined signaling. Therefore, Microwire devices are also supported by the SPI framework. Note that when referencing SPI devices in a config(1) file, the 'slave' must be provided, as SPI lacks any way to automatically probe devices. HARDWARE
NetBSD includes the following machine-independent SPI drivers m25p STMicroelectronics M25P family of NOR flash devices. tm121temp Texas Instruments TMP121 temperature sensor. SEE ALSO
m25p(4), tm121temp(4) HISTORY
The machine-independent SPI framework was written by Garrett D'Amore for the Champaign-Urbana Community Wireless Network Project (CUWiN), and appeared in NetBSD 4.0. BSD
October 9, 2006 BSD

Check Out this Related Man Page

STRUCT 
SPI_MASTER(9) Serial Peripheral Interface (S STRUCT SPI_MASTER(9) NAME
struct_spi_master - interface to SPI master controller SYNOPSIS
struct spi_master { struct device dev; s16 bus_num; u16 num_chipselect; u16 dma_alignment; u16 mode_bits; u16 flags; #define SPI_MASTER_HALF_DUPLEX BIT(0) #define SPI_MASTER_NO_RX BIT(1) #define SPI_MASTER_NO_TX BIT(2) int (* setup) (struct spi_device *spi); int (* transfer) (struct spi_device *spi,struct spi_message *mesg); void (* cleanup) (struct spi_device *spi); }; MEMBERS
dev device interface to this driver bus_num board-specific (and often SOC-specific) identifier for a given SPI controller. num_chipselect chipselects are used to distinguish individual SPI slaves, and are numbered from zero to num_chipselects. each slave has a chipselect signal, but it's common that not every chipselect is connected to a slave. dma_alignment SPI controller constraint on DMA buffers alignment. mode_bits flags understood by this controller driver flags other constraints relevant to this driver setup updates the device mode and clocking records used by a device's SPI controller; protocol code may call this. This must fail if an unrecognized or unsupported mode is requested. It's always safe to call this unless transfers are pending on the device whose settings are being modified. transfer adds a message to the controller's transfer queue. cleanup frees controller-specific state DESCRIPTION
Each SPI master controller can communicate with one or more spi_device children. These make a small bus, sharing MOSI, MISO and SCK signals but not chip select signals. Each device may be configured to use a different clock rate, since those shared signals are ignored unless the chip is selected. The driver for an SPI controller manages access to those devices through a queue of spi_message transactions, copying data between CPU memory and an SPI slave device. For each such message it queues, it calls the message's completion function when the transaction completes. COPYRIGHT
Kernel Hackers Manual 2.6. July 2010 STRUCT SPI_MASTER(9)
Man Page

3 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

awk pattern search and put in a file

hi I am doing a task that is i have to search for multiple pattern from a file's 9 th column and then redirect it to a new file awk -F, 'BEGIN {OSF=","} { if ($9 == "OTF") print $0}' test1.tsv > test.tsv and the patterns are OST. ODI,MIN LIKE OTF Bit not getting the desired output... (11 Replies)
Discussion started by: pranabrana
11 Replies

2. UNIX for Dummies Questions & Answers

modprobe spi_bitbang results in error messages

Hi, I'm having a problem with the voyage linux distribution. I've been busy to include a CAN driver, which uses the SPI bus to communicate. While I was busy debugging the code, everything worked fine while performing a modprobe of the SPI driver to get it all running. But the... (1 Reply)
Discussion started by: nistap
1 Replies

3. Programming

How to init the SPI device in daemon?

I have to make a linux monitoring daemon that works with a SPI device (/dev/spidev). However, I always failed to init this SPI device. The return error code is 25, which means "inappropriate ioctl for device". As I know, daemon runs in background and doesn't have a control terminal and this might... (3 Replies)
Discussion started by: bus147
3 Replies