Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

accf_data(9) [netbsd man page]

ACCF_DATA(9)						   BSD Kernel Developer's Manual					      ACCF_DATA(9)

NAME
accf_data -- buffer incoming connections until data arrives SYNOPSIS
options INET pseudo-device accf_data DESCRIPTION
This is a filter to be placed on a socket that will be using accept() to receive incoming connections. It prevents the application from receiving the connected descriptor via accept() until data arrives on the connection. EXAMPLES
If the accf_data accept filter is present in the kernel configuration, this will enable the data accept filter on the socket sok. struct accept_filter_arg afa; bzero(&afa, sizeof(afa)); strcpy(afa.af_name, "dataready"); setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa)); SEE ALSO
setsockopt(2), accept_filter(9), accf_http(9) HISTORY
The accept filter mechanism and the accf_data filter were introduced in FreeBSD 4.0. They were ported to NetBSD by Coyote Point Systems and appeared in NetBSD 5.0. AUTHORS
This manual page and the filter were written by Alfred Perlstein. BSD
August 10, 2008 BSD

Check Out this Related Man Page

ACCF_HTTP(9)						   BSD Kernel Developer's Manual					      ACCF_HTTP(9)

NAME
accf_http -- buffer incoming connections until a certain complete HTTP requests arrive SYNOPSIS
options INET pseudo-device accf_http DESCRIPTION
This is a filter to be placed on a socket that will be using accept() to receive incoming HTTP connections. Once installed on a listening socket, this filter is activated when a connection becomes ready to receive data (at which point accept(2) would usually return the connected descriptor to the application). The filter prevents the descriptor from being returned immediately to the application via accept(2). The descriptor is made available to the application via accept(2) only when one of the following conditions is met: 1. A complete, syntactically valid HTTP/1.0 or HTTP/1.1 HEAD or GET request has been buffered by the kernel. 2. The data buffered by the kernel cannot be part of a complete, syntactically valid HTTP 1.0 or HTTP/1.1 HEAD or GET request. The utility of accf_http is that a server will not have to context switch several times before performing the initial parsing of the request. This effectively reduces the amount of required CPU utilization to handle incoming requests by keeping active processes in preforking servers such as Apache low and reducing the size of the file descriptor set that needs to be managed by interfaces such as select(), poll() or kevent() based servers. EXAMPLES
If the accf_data accept filter is present in the kernel configuration, this will enable the http accept filter on the socket sok. struct accept_filter_arg afa; bzero(&afa, sizeof(afa)); strcpy(afa.af_name, "httpready"); setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa)); SEE ALSO
setsockopt(2), accept_filter(9) HISTORY
The accept filter mechanism and the accf_http filter were introduced in FreeBSD 4.0. They were ported to NetBSD by Coyote Point Systems and appeared in NetBSD 5.0. AUTHORS
This manual page and the filter were written by Alfred Perlstein. BSD
September 4, 2008 BSD
Man Page