Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

bzero(9) [netbsd man page]

BZERO(9)						   BSD Kernel Developer's Manual						  BZERO(9)

NAME
bzero -- write zeroes to a byte string SYNOPSIS
#include <sys/systm.h> void bzero(void *b, size_t len); DESCRIPTION
The bzero() interface is obsolete. Do not add new code using it. It will soon be purged. Use memset(9) instead. (The bzero() function is now a macro for memset(9).) The bzero() function writes len zero bytes to the string b. If len is zero, bzero() does nothing. SEE ALSO
memset(9) BSD
July 7, 2001 BSD

Check Out this Related Man Page

BSTRING(3)						   BSD Library Functions Manual 						BSTRING(3)

NAME
bcmp, bcopy, bzero, memccpy, memchr, memcmp, memcpy, memmove, memset -- byte string operations LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <strings.h> int bcmp(const void *s1, const void *s2, size_t n); void bcopy(const void *s1, void *s2, size_t n); void bzero(void *s, size_t n); #include <string.h> void * memccpy(void *restrict s1, const void *restrict s2, int c, size_t n); void * memchr(const void *s, int c, size_t n); int memcmp(const void *s1, const void *s2, size_t n); void * memcpy(void *restrict s1, const void *restrict s2, size_t n); void * memmove(void *s1, const void *s2, size_t n); void * memset(void *s, int c, size_t n); DESCRIPTION
These functions operate on variable length strings of bytes. They do not check for terminating null bytes, as the routines listed in string(3) do. See the specific manual pages for more information. LEGACY SYNOPSIS
#include <string.h> The include file <string.h> is necessary and sufficient for all functions. SEE ALSO
bcmp(3), bcopy(3), bzero(3), memccpy(3), memchr(3), memcmp(3), memcpy(3), memmove(3), memset(3), compat(5) STANDARDS
The functions memchr(), memcmp(), memcpy(), memmove(), and memset() conform to ISO/IEC 9899:1990 (``ISO C90''). HISTORY
The functions bzero() and memccpy() appeared in 4.3BSD; the functions bcmp(), bcopy(), appeared in 4.2BSD. BSD
June 4, 1993 BSD
Man Page