Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

dtoc(9) [netbsd man page]

CTOD(9) 						   BSD Kernel Developer's Manual						   CTOD(9)

NAME
ctod -- macros related to bytes, pages, and disk blocks SYNOPSIS
#include <sys/param.h> size ctod(size x); size dtoc(size x); size ctob(size x); size btoc(size x); size dbtob(size x); size btodb(size x); DESCRIPTION
The ctod family of macros can be used to convert between bytes, pages (``clicks''), and disk blocks. The following table lists the possible conversions: Macro From To ctod() pages disk blocks dtoc() disk blocks pages ctob() pages bytes btoc() bytes pages dbtob() disk blocks bytes btodb() bytes disk blocks These are typical macros that may appear with different names in other operating systems. Examples include btop() and btopr() in Solaris. SEE ALSO
param(3) HISTORY
Some of these macros appeared in Version 7 AT&T UNIX. CAVEATS
The described macros make no assumptions about the type of the input parameter. A caller should ensure that neither integer overflow nor integer underflow are possible. BSD
April 8, 2011 BSD

Check Out this Related Man Page

ROUNDUP(9)						   BSD Kernel Developer's Manual						ROUNDUP(9)

NAME
roundup -- macros for counting and rounding SYNOPSIS
#include <sys/param.h> size howmany(x, size); size roundup(x, size); size rounddown(x, size); size roundup2(x, size); int powerof2(x); DESCRIPTION
The roundup() and rounddown() macros return an integer from rounding x up and down, respectively, to the next size. The howmany() macro in turn reveals how many times size fits into x, rounding the residual up. The roundup2() macro also rounds up, but with the assumption that size is a power of two. If x is indeed a power of two, powerof2() return 1. RETURN VALUES
The return value is an integer from the respective operation. If x is 0, all macros except powerof2() return 0. The behavior is undefined if size is 0. EXAMPLES
The following example rounds the variable rx to a 32-bit boundary: uint16_t rx; ... rx = roundup2(rx, sizeof(uint32_t)); SEE ALSO
ilog2(3), param(3), imax(9) CAVEATS
All described macros make no assumptions about the type of the parameters. These are implicitly assumed to be unsigned integers. BSD
June 1, 2011 BSD
Man Page

12 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Need logic for check automated Job work in awk or SED.

I have a Java program which will automatically trigger some scheduled job to update Db or some other work. I am tracking the jobs with log messages and finding out it is properly run or not. I want to write a script to capture it correctly on time. Say Job1 is running on 15, 30, and 45 every... (5 Replies)
Discussion started by: senthilkumar_ak
5 Replies

2. Shell Programming and Scripting

Issue with passing variable to Grep in a shell script

Hi, I'm trying to check if methods specified in a class have been added to the corrosponding interface. My code below is giving me the following errors: grep: function: No such file or directory grep: import($zipfile): No such file or directory grep: function: No such file or... (1 Reply)
Discussion started by: racshot65
1 Replies

3. AIX

AIX Tivoli Image Restore

Dear Team: I am new to this Forum and I need your help for my AIX restoration problem its very urgent my problem as follow failure I have a Tivoli Storage Manger was installed on that server. I created backup image using Tivoli and it created a set of files each file is around 2GB so... (1 Reply)
Discussion started by: Firas_Abed
1 Replies

4. Shell Programming and Scripting

Searching Alphanumeric Character From a File

Hi, In a error log file, the error code of a particular error contains both Alphabet and Numbers. My problem statement is to find the error codes from a particular log. That means, I need to search a word, which contains both alphabet and number. Please help me. Below is two examples of error... (1 Reply)
Discussion started by: snehasish_jana
1 Replies

5. Shell Programming and Scripting

Find logs between two timestamp

Suppose there are log entries like 16 Jul 2012 11:46:45,628 SendToClientService ExecuteThread: '256' for queue: 'weblogic.kernel.Default (self-tuning)': Received an unknown fault. 16 Jul 2012 11:47:45,650 SendToClientService ExecuteThread: '256' for queue: 'weblogic.kernel.Default... (4 Replies)
Discussion started by: snehasish_jana
4 Replies

6. Solaris

Sun blade 1500 bad magic number

Good afternoon all, First, sorry for my English, this is not my first language but I try my best :). So, here we go. A friend of mine gave me an old Sun Blade 1500 he wasn't using. He said it was working fine except for the missing hard drive. I had in my IT personnal box an old IDE... (33 Replies)
Discussion started by: firstpost
33 Replies

7. Programming

Help with Graphs (BFS mostly)

Okay so I posted a thread about my project before, how I need to create generated word ladders and all that. Now I am to the point where I need to create a method which will find the shortests path between a start word and an end word. For example: startWord: Head endWord: Feet And then a... (3 Replies)
Discussion started by: SilvarHawke
3 Replies

8. Programming

Trouble with Iterators and Hashtables (Java)

Okay so I am currently workng on an assignment where I have basically got to create a word ladder, eg. Click, Clock, Flock, Flick, so its a list of words with only 1 letter difference, and the same letters cant be reused. Now I can do 2 methods of doing this, the first (which I need help need help... (2 Replies)
Discussion started by: SilvarHawke
2 Replies

9. Solaris

ERROR: Copy of CD image failed

Hi I tried to boot as single-user mode on my sunfire t1000 to change my root password since the guy has left the company without give us the root password. anyhow since this machine not have attached with cd/dvd/usb so the only think that to do it through Jumpstart now i tried to... (8 Replies)
Discussion started by: jmishal
8 Replies

10. Solaris

Can ufsdump create files that have a .vtoc and .dmp extension?

Hello, I was handed the job of restoring a drive on a old Sun Micro server running Solaris 8. The person who created the backup files told me I would need to use UFSrestore to restore the drive. I have read about everything on ufsrestore that is on this forum and have a decent grasp on how it... (18 Replies)
Discussion started by: CurtArnold
18 Replies

11. Shell Programming and Scripting

Newbie needs help with some bash scripting

Please bear with me, I'm a beginner but have had some experience and decent knowledge to understand things as I read them and I'm in the process of trying to learn more. I recently inherited a UNIX server which has a bash script which is part of a crontab schedule that needs to be modified (or... (3 Replies)
Discussion started by: Danylko
3 Replies

12. Shell Programming and Scripting

Learning to Script in Linux

Hello, I'm trying to branch out and learn Linux, but my comfort zone is PowerShell. I figure the best way to learn it is to do it so I moved my Plex Media Server to Ubuntu Server. What I'm trying to do is build a script that searches a directory and all subdirectories for files with the .ts... (5 Replies)
Discussion started by: Rhysers
5 Replies