Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

enosys(9) [netbsd man page]

NULLOP(9)						   BSD Kernel Developer's Manual						 NULLOP(9)

NAME
nullop -- dummy functions SYNOPSIS
#include <sys/systm.h> int nullop(void *v); void voidop(void); int enodev(void); int enxio(void); int enoioctl(void); int enosys(void); int eopnotsupp(void); DESCRIPTION
The nullop() function provides a generic ``null operation''. It always returns the value 0. The voidop() function takes no arguments and does nothing. The enodev(), enxio(), enoioctl(), enosys(), and eopnotsupp() functions always fail, returning ENODEV, ENXIO, ENOTTY, ENOSYS, and EOPNOTSUPP, respectively. EXAMPLES
The following example demonstrates a case where nullop() may be useful: uint64_t xc; ... xc = xc_broadcast(0, (xcfunc_t)nullop, NULL, NULL); xc_wait(xc); BSD
July 25, 2010 BSD

Check Out this Related Man Page

UCAS(9) 						   BSD Kernel Developer's Manual						   UCAS(9)

NAME
ucas -- atomic memory operations on user-space address SYNOPSIS
#include <sys/systm.h> int ucas_ptr(volatile void *uptr, void *old, void *new, void *retp); int ucas_int(volatile int *uptr, int old, int new, int *retp); DESCRIPTION
These functions provide compare-and-swap (CAS) functionality on user-space address. Except that they can be safely used for the kernel to access user-space address, they are semantically equivalents of atomic_cas(3). uptr The pointer to the variable. This should be a user-space pointer. old The value to compare with the variable. new The value to store to the variable. retp The pointer to the memory to store the old value of the variable. RETURN VALUES
On success, these functions return 0. In that case, the caller can consult the value returned via retp to check the result of the CAS opera- tion. Otherwise, these functions return an appropriate errno(9) error code, typically EFAULT. SEE ALSO
atomic_cas(3), intro(9) BUGS
Conceptually, the retp argument of ucas_ptr() would be of void **. The current prototype is a compromise for usability. BSD
October 24, 2011 BSD
Man Page

4 More Discussions You Might Find Interesting

1. Solaris

Core dump failures

Does anyone have a list of error codes when core dumps fail? What is error 4? I also have another box that does error-2 occasionally. if anyone has a list of these error codes, it would be appreciated, thanks! I have the error below: NOTICE: core_log: ns-admin core dump failed,... (2 Replies)
Discussion started by: BG_JrAdmin
2 Replies

2. Solaris

/var/cron/log Return Codes

I want to know if there is any documentation or any type of information that can give a list of all of the return codes that can be seen in the /var/cron/log. I have seen a couple in my log file. Example: rc=1 and rc=64. (2 Replies)
Discussion started by: sjames
2 Replies

3. UNIX for Advanced & Expert Users

System Call Wrapper of 'open'

When the programmer use 'open' function, the process is like below. "open -> system call wrapper of open in Glibc -> syscall_open in kernel" I found the wrapper of open, but there is no implementation like 'int $80'. int __open (file, oflag) const char *file; int oflag; { ... (3 Replies)
Discussion started by: yuno96
3 Replies

4. Red Hat

How to install expect after installing tcl on Redhat Linux

Hi, I have install tcl and then expect but I am getting below ouput while trying which expect which expect /usr/bin/which: no expect in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin) I have copied both in... (6 Replies)
Discussion started by: manish_1678
6 Replies