Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

enxio(9) [netbsd man page]

NULLOP(9)						   BSD Kernel Developer's Manual						 NULLOP(9)

NAME
nullop -- dummy functions SYNOPSIS
#include <sys/systm.h> int nullop(void *v); void voidop(void); int enodev(void); int enxio(void); int enoioctl(void); int enosys(void); int eopnotsupp(void); DESCRIPTION
The nullop() function provides a generic ``null operation''. It always returns the value 0. The voidop() function takes no arguments and does nothing. The enodev(), enxio(), enoioctl(), enosys(), and eopnotsupp() functions always fail, returning ENODEV, ENXIO, ENOTTY, ENOSYS, and EOPNOTSUPP, respectively. EXAMPLES
The following example demonstrates a case where nullop() may be useful: uint64_t xc; ... xc = xc_broadcast(0, (xcfunc_t)nullop, NULL, NULL); xc_wait(xc); BSD
July 25, 2010 BSD

Check Out this Related Man Page

UCAS(9) 						   BSD Kernel Developer's Manual						   UCAS(9)

NAME
ucas -- atomic memory operations on user-space address SYNOPSIS
#include <sys/systm.h> int ucas_ptr(volatile void *uptr, void *old, void *new, void *retp); int ucas_int(volatile int *uptr, int old, int new, int *retp); DESCRIPTION
These functions provide compare-and-swap (CAS) functionality on user-space address. Except that they can be safely used for the kernel to access user-space address, they are semantically equivalents of atomic_cas(3). uptr The pointer to the variable. This should be a user-space pointer. old The value to compare with the variable. new The value to store to the variable. retp The pointer to the memory to store the old value of the variable. RETURN VALUES
On success, these functions return 0. In that case, the caller can consult the value returned via retp to check the result of the CAS opera- tion. Otherwise, these functions return an appropriate errno(9) error code, typically EFAULT. SEE ALSO
atomic_cas(3), intro(9) BUGS
Conceptually, the retp argument of ucas_ptr() would be of void **. The current prototype is a compromise for usability. BSD
October 24, 2011 BSD
Man Page