Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

flash(9) [netbsd man page]

FLASH(9)						   BSD Kernel Developer's Manual						  FLASH(9)

NAME
flash -- subsystem for flash-like memory devices SYNOPSIS
#include <dev/flash/flash.h> device_t flash_attach_mi(const struct flash_interface *fl, device_t dev); DESCRIPTION
Flash-like devices can register themselves to the flash layer with the flash_hw_if structure. This structure has function pointers and other fields. The attachment can be done by calling flash_attach_mi() with this structure and the device's device_t as an argument. Return value is the flash layer device. The flash_interface structure is shown below. struct flash_interface { int (*erase) (device_t, struct flash_erase_instruction *); int (*read) (device_t, off_t, size_t, size_t *, uint8_t *); int (*write) (device_t, off_t, size_t, size_t *, const uint8_t *); int (*block_markbad)(device_t, uint64_t); int (*block_isbad)(device_t, uint64_t); int (*sync) (device_t); int (*submit)(device_t, struct buf *); /* storage for partition info */ struct flash_partition partition; /* total size of mtd */ flash_addr_t size; uint32_t page_size; uint32_t erasesize; uint32_t writesize; uint32_t minor; uint8_t type; }; SEE ALSO
flash(4), nand(9) AUTHORS
Adam Hoka <ahoka@NetBSD.org> BSD
March 31, 2011 BSD

Check Out this Related Man Page

DEVICE_GET_STATE(9)					   BSD Kernel Developer's Manual				       DEVICE_GET_STATE(9)

NAME
device_get_state, device_busy, device_unbusy, device_is_alive, device_is_attached -- manipulate device state SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> device_state_t device_get_state(device_t dev); void device_busy(device_t dev); void device_unbusy(device_t dev); int device_is_alive(device_t dev); int device_is_attached(device_t dev); DESCRIPTION
The current state of a device is accessed by calling device_get_state() which returns DS_NOTPRESENT, DS_ALIVE, DS_ATTACHED or DS_BUSY (described in device(9)). To test see if a device was successfully probed, call device_is_alive() which simply returns if the state is greater or equal to DS_ALIVE. To test see if a device was successfully attached, call device_is_attached() which simply returns if the state is greater or equal to DS_ATTACHED. Each device has a busy count which is incremented when device_busy() is called and decremented when device_unbusy() is called. Both routines return an error if the device state is less than DS_ATTACHED. When device_busy() is called on a device in the DS_ATTACHED state, the device changes to the DS_BUSY state. When device_unbusy() is called and after decrementing, the busy count for the device is zero, the device changes to the DS_ATTACHED state. SEE ALSO
device(9) AUTHORS
This manual page was written by Doug Rabson. BSD
June 16, 1998 BSD
Man Page

14 More Discussions You Might Find Interesting

1. Post Here to Contact Site Administrators and Moderators

Our First Flash Intro ?

Well, someone created a flash intro for us (their first attempt at SWiSH!) OK, SECOND DRAFT: https://www.unix.com/test_intro2.swf --------------------------- FIRST DRAFT: https://www.unix.com/test_intro1.swf Notice it says "Search before posting a question"..... Well????... (24 Replies)
Discussion started by: Neo
24 Replies

2. Post Here to Contact Site Administrators and Moderators

New Flash intro from Forum Member.....

New submission for flash intro: What do you think? (2 Replies)
Discussion started by: Neo
2 Replies

3. HP-UX

Mozilla & Macromedia Flash Player Plugin Problem

Hello All, I am using Mozilla 1.7.8 on hp-ux 11.00, and install flash player 6 for it. it is giving following errors and get crashed. when i want to open a site need flash plugin. Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget' Gtk-WARNING **: invalid cast from `GtkSuperWin'... (1 Reply)
Discussion started by: Awadhesh
1 Replies

4. UNIX for Dummies Questions & Answers

Mounting a flash device

How do you mount a USB flash drive on Sun Blade 2000 or 2500 with solaris 8? Thanks in advance ;) (1 Reply)
Discussion started by: xeroxtechnician
1 Replies

5. Solaris

Flash Archive built on a 490 going to a 890

I am going to build a flash archive on a v490 and put it on 3 890's I have coming in. Someone had mentioned to me that they thought I might have a problem booting, something about the wrong boot block. Has anyone heard this before , or do you think I would have any other issues. I know of... (3 Replies)
Discussion started by: BG_JrAdmin
3 Replies

6. Solaris

Problem installing Solaris on a V890 using flash

I am trying to use a flash image to install a v890. I have the image on another box. I am trying to use ftp to pull down the image. But, when i go though the install, choose flash, enter the ftp info, it can not ever connect to the server. I've never had this trouble before. There are 4... (4 Replies)
Discussion started by: BG_JrAdmin
4 Replies

7. Ubuntu

USB flash drive/keyfob will not automount

I am working on an Ubuntu Linux 8.10 system that I do not want to reboot. For some reason, USB flash drives (mass storage devices) now no longer automount. I want to restore that functionality without rebooting. I can manually mount and unmount these things by doing: cd /media sudo mkdir thing... (4 Replies)
Discussion started by: ropers
4 Replies

8. Solaris

Flash Archives - A little bit of help :-)

Hi all Okay, I know how to make flash archives, and I even know how to split them and extract files. But, Ive never used one to restore an OS drive and I might have to. Ive search around google, and seen different ideas / ways, but havent really come to a definate answer. So, lets... (3 Replies)
Discussion started by: sbk1972
3 Replies

9. UNIX for Dummies Questions & Answers

Executing a sequence of commands as a single background process

I'm writing a PHP script which will take a given media file and convert it into a flash (flv) file. In addition to this, once the flv file has been generated I create two thumbnails (of different sizes) from the newly generated flv file. In order to do this I'm calling ffmpeg from the command... (4 Replies)
Discussion started by: phatphug
4 Replies

10. Solaris

Can I restore from a flash archive without re-entering the basic sys info?

Hi I would like to be able to take adhoc backups of my systems using flash archive - flarcreate - and then restore from them to the same system without having to enter the basic configuration again when I boot from the Solaris CD. So, I'd like to be able to create a flar archive ... (1 Reply)
Discussion started by: emjs
1 Replies

11. AIX

Flash Copy Problem, has any one else seen this?

Around a month ago we suffered a prolonged power outage, due to circumstances the servers and storage arrays were still in use when the UPS dropped. One of the servers was running a flash copy on the database while batch processing had commenced. This is the only server that suffered any further... (2 Replies)
Discussion started by: gull04
2 Replies

12. Shell Programming and Scripting

Copy file to SD card from internal flash.

Hi, At first I have to say that I know nothing about Linux :( But I am looking for solution how to copy one file from internal Lowrnace HDS flash memory. Lowrance HDS is Linux based device. Here is the link for firmware update files for this unit. At the end of main firmware file there... (62 Replies)
Discussion started by: PouchX
62 Replies

13. Shell Programming and Scripting

Row alignment

*1 flash read test(*do_test1*) PASS *2 xxxxxxxxxxx flash write test(*do_test2) FAIL ------>xxxxx *1 flash read test(*do_test1*) PASS *2 xxxxxxxxxxx flash write test(*do_test2) FAIL ------>xxxxx I want pass and Fail to be aligned if each line uses printf or echo to print, is... (5 Replies)
Discussion started by: yanglei_fage
5 Replies

14. UNIX for Beginners Questions & Answers

Regular Expressions : grab flash devices

I know its an art and it takes a little time .. but is there a better way to do this ? (sup-)?boot(disk|flash)|flash\d*|disk\d Thanks in advance Pop (1 Reply)
Discussion started by: popeye
1 Replies