Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ieee80211_crypto(9) [netbsd man page]

IEEE80211_CRYPTO(9)					   BSD Kernel Developer's Manual				       IEEE80211_CRYPTO(9)

NAME
ieee80211_crypto_attach, ieee80211_crypto_detach, ieee80211_crypto_encap -- 802.11 WEP encryption functions SYNOPSIS
void ieee80211_crypto_attach(struct ieee80211com *ic); void ieee80211_crypto_detach(struct ieee80211com *ic); struct ieee80211_key * ieee80211_crypto_encap(struct ieee80211com *ic, struct ieee80211_node *ni, struct mbuf *m0); DESCRIPTION
These functions provide encryption support for 802.11 device drivers. The ieee80211_crypto_attach() function initializes crypto support for the interface ic. The default is null crypto. The ieee80211_crypto_detach() function frees data structures associated with crypto support for the interface ic. The two above functions are automatically called by the interface attach and detach routines, respectively. The ieee80211_crypto_encap() function encapsulates the packet supplied in mbuf m0, with the crypto headers given the for node ni. Software encryption is possibly performed. In case of no specified key for ni or multicast traffic, the default key for the interface ic is used for encapsulation. The key is returned in the case of successful encapsulation, otherwise NULL is returned. SEE ALSO
ieee80211(9) HISTORY
The ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6. AUTHORS
This man page was written by Bruce M. Simpson <bms@FreeBSD.org> and Darron Broad <darron@kewl.org>. BSD
September 12, 2006 BSD

Check Out this Related Man Page

IEEE80211_IOCTL(9)					   BSD Kernel Developer's Manual					IEEE80211_IOCTL(9)

NAME
ieee80211_cfgget, ieee80211_cfgset, ieee80211_ioctl -- 802.11 interface ioctl commands SYNOPSIS
#include <net80211/ieee80211_var.h> #include <net80211/ieee80211_proto.h> #include <net80211/ieee80211_ioctl.h> int ieee80211_cfgget(struct ieee80211com *ic, u_long cmd, void *data); int ieee80211_cfgset(struct ieee80211com *ic, u_long cmd, void *data); int ieee80211_ioctl(struct ieee80211com *ic, u_long cmd, void *data); DESCRIPTION
These functions are typically invoked by drivers in response to requests for information or to change settings from the userland. The ieee80211_cfgget() and ieee80211_cfgset() functions implement a legacy interface for getting and setting 802.11 interface attributes respectively. The interface is compatible with the RIDs implemented by the wi(4) driver and used by the wiconfig(8) utility. The ieee80211_ioctl() function implements ioctls such as key management for wireless devices. Ioctls related to the Ethernet layer also pass through here, but are handed off to ether_ioctl() when no match for cmd is found. SEE ALSO
wi(4), ifconfig(8), wiconfig(8), ieee80211(9) HISTORY
The ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6. AUTHORS
This man page was written by Bruce M. Simpson <bms@FreeBSD.org> and Darron Broad <darron@kewl.org>. BSD
September 12, 2006 BSD
Man Page

13 More Discussions You Might Find Interesting

1. Tips and Tutorials

Unix File Permissions

Introduction I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls: $ ls -ld /usr/bin /usr/bin/cat drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin -r-xr-xr-x 1 bin bin ... (6 Replies)
Discussion started by: Perderabo
6 Replies

2. Shell Programming and Scripting

sorting left-justified numeric values

I have a file which looks roughly like this: 996 mmmmmmm 996 xxxxxxxxxxxxx 99600 ssssssssss 9964 fffffffffffff and would like to sort it numerically on the first field. I tried: sort -nr --key=1 .... The output I get is: 99600 ssssssssss 9964 ... (3 Replies)
Discussion started by: rovf
3 Replies

3. Programming

Memory Leaks

Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram. main() { malloc(1gb) return(0) } The program above exits without freeing the memory. In this case will the 1 gb of heap memory be returned... (9 Replies)
Discussion started by: rupeshkp728
9 Replies

4. Solaris

How to install PGX32 on Sparc 10 Ultra?

I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10. I've got the Oracle installation guide for it and I got as far as: "4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive." I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Discussion started by: Michele31416
21 Replies

5. Shell Programming and Scripting

Better to Use Return Code or wc -l Output?

Hey All, Quick question... I'm writing a short script to check if a continuous port is running on a server. I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the return code from the command or if its better to pipe to... (12 Replies)
Discussion started by: mrm5102
12 Replies

6. Shell Programming and Scripting

Vm versus physical linux server

Does anyone have a script that can be run to tell you if you are on either a VM Linux or a physical Linux server? (15 Replies)
Discussion started by: bigbenn
15 Replies

7. BSD

NetBSD 6.1.2: apm and admd not found

I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system? Is it necessary to recompile the default amd64 kernel to use apm? Or is there a new method for power management and suspend/resume? (2 Replies)
Discussion started by: bsdx
2 Replies

8. Shell Programming and Scripting

RFC - Korn shell prompt

Hi, I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD. So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post. The prompt is... (2 Replies)
Discussion started by: gezley
2 Replies

9. Shell Programming and Scripting

Make bold chars in UNIX

Hi all, I want to make the string as bold in unix. is there any way to acheive this? thanks in advance. (16 Replies)
Discussion started by: SekhaReddy
16 Replies

10. Shell Programming and Scripting

Adding a List of Times

Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Discussion started by: Brusimm
5 Replies

11. UNIX for Beginners Questions & Answers

BSD Unix Toolbox: 1000+ Commands for FreeBSD, OpenBSD, and NetBSD

Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;) But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
Discussion started by: fossiili
0 Replies

12. UNIX for Beginners Questions & Answers

Grandpa returning to UNIX

On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)
Discussion started by: fossiili
13 Replies

13. UNIX for Beginners Questions & Answers

Grep command to show the number of results

Hi I wanted to know if there is an option in grep command to show the number of results (not the number of lines of findings). Thanks (14 Replies)
Discussion started by: abdossamad2003
14 Replies