Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

memmove(9) [netbsd man page]

MEMMOVE(9)						   BSD Kernel Developer's Manual						MEMMOVE(9)

NAME
memmove -- copy byte string SYNOPSIS
#include <sys/systm.h> void * memmove(void *dst, const void *src, size_t len); DESCRIPTION
The memmove() function copies len bytes from string src to string dst. The two strings may overlap; the copy is always done in a non- destructive manner. RETURN VALUES
The memmove() function returns the original value of dst. SEE ALSO
memcpy(9) STANDARDS
The memmove() function conforms to ANSI X3.159-1989 (``ANSI C89''). BSD
July 7, 2001 BSD

Check Out this Related Man Page

BSTRING(3)						   BSD Library Functions Manual 						BSTRING(3)

NAME
memccpy, memchr, memcmp, memcpy, memmem, memmove, memset -- byte string operations LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <string.h> void * memchr(const void *b, int c, size_t len); int memcmp(const void *b1, const void *b2, size_t len); void * memccpy(void *dst, const void *src, int c, size_t len); void * memcpy(void *dst, const void *src, size_t len); void * memmem(const void *block, size_t blen, const void *pat, size_t plen); void * memmove(void *dst, const void *src, size_t len); void * memset(void *b, int c, size_t len); DESCRIPTION
These functions operate on variable length strings of bytes. They do not check for terminating nul bytes as the routines listed in string(3) do. See the specific manual pages for more information. SEE ALSO
memccpy(3), memchr(3), memcmp(3), memcpy(3), memmem(3), memmove(3), memset(3) STANDARDS
The functions memchr(), memcmp(), memcpy(), memmove(), and memset() conform to ANSI X3.159-1989 (``ANSI C89''). HISTORY
The function memccpy() appeared in 4.3BSD. BSD
February 9, 2007 BSD
Man Page