Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

powerhook_establish(9) [netbsd man page]

POWERHOOK_ESTABLISH(9)					   BSD Kernel Developer's Manual				    POWERHOOK_ESTABLISH(9)

NAME
powerhook_establish, powerhook_disestablish -- add or remove a power change hook SYNOPSIS
void * powerhook_establish(const char *name, void (*fn)(int why, void *a), void *arg); void powerhook_disestablish(void *cookie); DESCRIPTION
The powerhook_establish API is deprecated. The powerhook_establish() function adds fn of the list of hooks invoked by dopowerhooks(9) at power change. When invoked, the hook function fn will be passed the new power state as the first argument and arg as its second argument. The powerhook_disestablish() function removes the hook described by the opaque pointer cookie from the list of hooks to be invoked at power change. If cookie is invalid, the result of powerhook_disestablish() is undefined. Power hooks should be used to perform activities that must happen when the power situation to the computer changes. Because of the environ- ment in which they are run, power hooks cannot rely on many system services (including file systems, and timeouts and other interrupt-driven services). The power hooks are typically executed from an interrupt context. The different reasons for calling the power hooks are: suspend, standby, and resume. The reason is reflected in the why argument and the values PWR_SOFTSUSPEND, PWR_SUSPEND, PWR_SOFTSTANDBY, PWR_STANDBY, PWR_SOFTRESUME, and PWR_RESUME. It calls with PWR_SOFTxxx in the normal priority level while the other callings are protected with splhigh(9). At suspend the system is going to lose (almost) all power, standby retains some power (e.g., minimal power to USB devices), and at resume power is back to normal. RETURN VALUES
If successful, powerhook_establish() returns an opaque pointer describing the newly-established power hook. Otherwise, it returns NULL. SEE ALSO
dopowerhooks(9) BSD
May 14, 2009 BSD

Check Out this Related Man Page

power(9E)							Driver Entry Points							 power(9E)

NAME
power - power a device attached to the system SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int prefixpower(dev_info_t *dip, int component, int level); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This entry point is required. If the driver writer does not supply this entry point, the value NULL must be used in the cb_ops(9S) structure instead. PARAMETERS
dip Pointer to the device's dev_info structure. component Component of the driver to be managed. level Desired component power level. DESCRIPTION
The power(9E) function is the device-specific Power Management entry point. This function is called when the system wants the driver to set the power level of component to level. The level argument is the driver-defined power level to which the component needs to be set. Except for power level 0, which is interpreted by the framework to mean "powered off," the interpretation of level is entirely up to the driver. The component argument is the component of the device to be power-managed. The interpretation of component is entirely up to the driver. When a requested power transition would cause the device to lose state, the driver must save the state of the device in memory. When a requested power transition requires state to be restored, the driver must restore that state. If a requested power transition for one component requires another component to change power state before it can be completed, the driver must call pm_raise_power(9F) to get the other component changed, and the power(9E) entry point must support being re-entered. If the system requests an inappropriate power transition for the device (for example, a request to power down a device which has just become busy), then the power level should not be changed and power should return DDI_FAILURE. RETURN VALUES
The power() function returns: DDI_SUCCESS Successfully set the power to the requested level. DDI_FAILURE Failed to set the power to the requested level. CONTEXT
The power() function is called from user or kernel context only. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
attach(9E), detach(9E), pm_busy_component(9F), pm_idle_component(9F), pm_raise_power(9F), cb_ops(9S) Writing Device Drivers Using Power Management SunOS 5.11 12 Dec 2003 power(9E)
Man Page