Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

profhz(9) [netbsd man page]

HZ(9)							   BSD Kernel Developer's Manual						     HZ(9)

NAME
hz, tick, tickadj, stathz, profhz -- system time model SYNOPSIS
#include <sys/kernel.h> extern int hz; extern int tick; extern int tickadj; extern int stathz; extern int profhz; DESCRIPTION
The essential clock handling routines in NetBSD are written to operate with two timers that run independently of each other. The main clock, running hz times per second, is used to keep track of real time. In another words, hz specifies the number of times the hardclock(9) timer ticks per second. Normally hardclock(9) increments time by tick each time it is called. If the system clock has drifted, adjtime(2) may be used to skew this increment based on the rate of tickadj. The second timer is used to gather timing statistics. It also handles kernel and user profiling. If the second timer is programmable, it is randomized to avoid aliasing between the two clocks. The mean frequency of the second timer is stathz. If a separate clock is not avail- able, stathz is set to hz. If profiling is enabled, the clock normally used to drive stathz may be run at a higher rate profhz, which is required to be a multiple of stathz. This will give higher resolution profiling information. These system variables are also available as struct clockinfo from sysctl(3) and kern.clockrate from sysctl(8). The hz is hardware-depen- dent; it can be overridden (if the machine dependent code supports this) by defining HZ in the kernel configuration file (see options(4)). Only override the default value if you really know what you are doing. SEE ALSO
adjtime(2), callout(9), hardclock(9), microtime(9), time_second(9) BSD
March 25, 2010 BSD

Check Out this Related Man Page

tickadj(1)						      General Commands Manual							tickadj(1)

NAME
tickadj - set time-related kernel variables SYNOPSIS
tickadj [ -Aqs ] [ -a tickadj ] [ -t tick ] DESCRIPTION
The tickadj program reads, and optionally modifies, several timekeeping-related variables in the running kernel in some machines, via /dev/kmem . The particular variables it is concerned with are tick , which is the number of microseconds added to the system time during a clock interrupt, tickadj , which sets the slew rate and resolution used by the adjtime system call, and dosynctodr , which indicates to the kernels on some machines whether they should internally adjust the system clock to keep it in line with time-of-day clock or not. By default, with no arguments, tickadj reads the variables of interest in the kernel and displays them. At the same time, it determines an "optimal" value for the value of the tickadj variable if the intent is to run the ntpd Network Time Protocol (NTP) daemon, and prints this as well. Since the operation of tickadj when reading the kernel mimics the operation of similar parts of the ntpd program fairly closely, this can be useful when debugging problems with ntpd . Note that tickadj should be run with some caution when being used for the first time on different types of machines. The operations which tickadj tries to perform are not guaranteed to work on all Unix machines and may in rare cases cause the kernel to crash. COMMAND LINE OPTIONS
-a tickadj Set the kernel variable tickadj to the value tickadj specified. -A Set the kernel variable tickadj to an internally computed "optimal" value. -t tick Set the kernel variable tick to the value tick specified. -s Set the kernel variable dosynctodr to zero, which disables the hardware time-of-year clock, a prerequisite for running the ntpd daemon under SunOS4. -q Normally, tickadj is quite verbose about what it is doing. The -q flag tells it to shut up about everything except errors. FILES
/vmunix /unix /dev/kmem BUGS
Fiddling with kernel variables at run time as a part of ordinary operations is a hideous practice which is only necessary to make up for deficiencies in the implementation of adjtime in many kernels and/or brokenness of the system clock in some vendors' kernels. It would be much better if the kernels were fixed and the tickadj program went away. SEE ALSO
More documentation is available in the package ntp-doc. AUTHOR
David L. Mills <mills@udel.edu> ntp 4.1.1b-r5 tickadj(1)
Man Page