Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

setjmp(9) [netbsd man page]

SETJMP(9)						   BSD Kernel Developer's Manual						 SETJMP(9)

NAME
setjmp, longjmp -- non-local jumps SYNOPSIS
#include <machine/types.h> #include <sys/systm.h> int setjmp(label_t *label); void longjmp(label_t *label); DESCRIPTION
The setjmp() function saves its calling environment in label. It returns zero on success. The longjmp() function restores the environment saved by the most recent invocation of setjmp(). It returns so that kernel execution continues as if the corresponding invocation of the setjmp() had just returned. setjmp() and longjmp() are a machine-independent interface for machine-dependent implementations. These functions are primarily used by ddb(4). SEE ALSO
ddb(4) BSD
May 23, 2002 BSD

Check Out this Related Man Page

SETJMP(3)							 Library functions							 SETJMP(3)

NAME
setjmp, sigsetjmp - save stack context for non-local goto SYNOPSIS
#include <setjmp.h> int setjmp(jmp_buf env); int sigsetjmp(sigjmp_buf env, int savesigs); DESCRIPTION
setjmp() and longjmp() are useful for dealing with errors and interrupts encountered in a low-level subroutine of a program. setjmp() saves the stack context/environment in env for later use by longjmp(). The stack context will be invalidated if the function which called setjmp() returns. sigsetjmp() is similar to setjmp(). If savesigs is nonzero, the set of blocked signals is saved in env and will be restored if a sig- longjmp() is later performed with this env. RETURN VALUE
setjmp() and sigsetjmp() return 0 if returning directly, and non-zero when returning from longjmp() using the saved context. CONFORMING TO
POSIX, ISO 9899 (C99) NOTES
POSIX does not specify whether setjmp will save the signal context. (In SYSV it will not. In BSD4.3 it will, and there is a function _setjmp that will not.) If you want to save signal masks, use sigsetjmp. setjmp() and sigsetjmp make programs hard to understand and maintain. If possible an alternative should be used. SEE ALSO
longjmp(3), siglongjmp(3) 1997-03-02 SETJMP(3)
Man Page