Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

stathz(9) [netbsd man page]

HZ(9)							   BSD Kernel Developer's Manual						     HZ(9)

NAME
hz, tick, tickadj, stathz, profhz -- system time model SYNOPSIS
#include <sys/kernel.h> extern int hz; extern int tick; extern int tickadj; extern int stathz; extern int profhz; DESCRIPTION
The essential clock handling routines in NetBSD are written to operate with two timers that run independently of each other. The main clock, running hz times per second, is used to keep track of real time. In another words, hz specifies the number of times the hardclock(9) timer ticks per second. Normally hardclock(9) increments time by tick each time it is called. If the system clock has drifted, adjtime(2) may be used to skew this increment based on the rate of tickadj. The second timer is used to gather timing statistics. It also handles kernel and user profiling. If the second timer is programmable, it is randomized to avoid aliasing between the two clocks. The mean frequency of the second timer is stathz. If a separate clock is not avail- able, stathz is set to hz. If profiling is enabled, the clock normally used to drive stathz may be run at a higher rate profhz, which is required to be a multiple of stathz. This will give higher resolution profiling information. These system variables are also available as struct clockinfo from sysctl(3) and kern.clockrate from sysctl(8). The hz is hardware-depen- dent; it can be overridden (if the machine dependent code supports this) by defining HZ in the kernel configuration file (see options(4)). Only override the default value if you really know what you are doing. SEE ALSO
adjtime(2), callout(9), hardclock(9), microtime(9), time_second(9) BSD
March 25, 2010 BSD

Check Out this Related Man Page

PROFIL(2)						      BSD System Calls Manual							 PROFIL(2)

NAME
profil -- control process profiling LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <unistd.h> int profil(char *samples, size_t size, vm_offset_t offset, int scale); DESCRIPTION
The profil() system call enables or disables program counter profiling of the current process. If profiling is enabled, then at every pro- filing clock tick, the kernel updates an appropriate count in the samples buffer. The frequency of the profiling clock is recorded in the header in the profiling output file. The buffer samples contains size bytes and is divided into a series of 16-bit bins. Each bin counts the number of times the program counter was in a particular address range in the process when a profiling clock tick occurred while profiling was enabled. For a given program counter address, the number of the corresponding bin is given by the relation: [(pc - offset) / 2] * scale / 65536 The offset argument is the lowest address at which the kernel takes program counter samples. The scale argument ranges from 1 to 65536 and can be used to change the span of the bins. A scale of 65536 maps each bin to 2 bytes of address range; a scale of 32768 gives 4 bytes, 16384 gives 8 bytes and so on. Intermediate values provide approximate intermediate ranges. A scale value of 0 disables profiling. RETURN VALUES
The profil() function returns the value 0 if successful; otherwise the value -1 is returned and the global variable errno is set to indicate the error. FILES
/usr/lib/gcrt0.o profiling C run-time startup file gmon.out conventional name for profiling output file ERRORS
The following error may be reported: [EFAULT] The buffer samples contains an invalid address. SEE ALSO
gprof(1) HISTORY
The profil() function appeared in Version 7 AT&T UNIX. BUGS
This routine should be named profile(). The samples argument should really be a vector of type unsigned short. The format of the gmon.out file is undocumented. BSD
June 4, 1993 BSD
Man Page