Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

sysmon_pswitch_event(9) [netbsd man page]

SYSMON_PSWITCH(9)					   BSD Kernel Developer's Manual					 SYSMON_PSWITCH(9)

NAME
sysmon_pswitch -- framework for power switches SYNOPSIS
#include <dev/sysmon/sysmonvar.h> int sysmon_pswitch_register(struct sysmon_pswitch *smpsw); void sysmon_pswitch_unregister(struct sysmon_pswitch *smpsw); void sysmon_pswitch_event(struct sysmon_pswitch *smpsw, int event); DESCRIPTION
The machine-independent sysmon_pswitch provides a framework for power management. The interface has been largely superceded by the pmf(9) framework, but sysmon_pswitch is still used to manage power switches as well as related mechanical adapters and buttons. These are encapsu- lated in the following structure: struct sysmon_pswitch { const char *smpsw_name; /* power switch name */ int smpsw_type; /* power switch type */ LIST_ENTRY(sysmon_pswitch) smpsw_list; }; Unsurprisingly, smpsw_name specifies the name of the power switch and smpsw_type defines the type of it. The following types are defined: PSWITCH_TYPE_POWER PSWITCH_TYPE_SLEEP PSWITCH_TYPE_LID PSWITCH_TYPE_RESET PSWITCH_TYPE_ACADAPTER PSWITCH_TYPE_HOTKEY If the type is PSWITCH_TYPE_HOTKEY, there are few predefined names that can be used for smpsw_name: PSWITCH_HK_DISPLAY_CYCLE display-cycle PSWITCH_HK_LOCK_SCREEN lock-screen PSWITCH_HK_BATTERY_INFO battery-info PSWITCH_HK_EJECT_BUTTON eject-button PSWITCH_HK_ZOOM_BUTTON zoom-button PSWITCH_HK_VENDOR_BUTTON vendor-button Once a power switch event has been proceeded, sysmon_pswitch will inform the user space powerd(8), which will possibly execute a script matching the type of the power switch. FUNCTIONS
After the sysmon_pswitch structure has been initialized, a new power switch device can be registered by using sysmon_pswitch_register(). The device can be detached from the framework by sysmon_pswitch_unregister(). The sysmon_pswitch_event() is used to signal a new power switch event. There are two possibilities for the value of event: PSWITCH_EVENT_PRESSED A button has been pressed, the lid has been closed, the AC adapter is off, etc. PSWITCH_EVENT_RELEASED A button has been released, the lid is open, the AC adapter is on, etc. The corresponding events in powerd(8) are pressed and released. SEE ALSO
powerd(8), pmf(9), sysmon_envsys(9), sysmon_taskq(9) AUTHORS
Jason R. Thorpe <thorpej@NetBSD.org> BSD
January 26, 2010 BSD

Check Out this Related Man Page

gnome-power-preferences(1)					   User Commands					gnome-power-preferences(1)

NAME
gnome-power-preferences - gnome power preferences GUI SYNOPSIS
gnome-power-preferences [--help] [--verbose] DESCRIPTION
gnome-power-preferences is a GUI configuration program. It enables you to configure your preferred desktop power management policies, e.g. blank screen when lid is closed, hibernate system when battery power is low, suspend system when power button is pressed, or let CPU fre- quency dynamically adjust based on process load. Then, these policies are enforced by gnome-power-manager(1). OPTIONS
This program follows the usual command line syntax, with long options starting with two dashes (`-'). A summary of options is included below. --help Show summary of options. --verbose Show extra debugging. EXAMPLES
Example 1: Launching gnome-power-preferences with the display of extra debugging messages. example% gnome-power-preferences --verbose EXIT STATUS
The following exit values are returned: 0 Application exited successfully >0 Application exited with failure FILES
The following files are used by this application: /usr/bin/gnome-power-preferences Executable for gnome power preferences GUI ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWgnome-power-manager | +-----------------------------+-----------------------------+ |Interface stability |Volatile | +-----------------------------+-----------------------------+ SEE ALSO
gnome-power-manager(1), gnome-power-statistics(1), attributes(5) NOTES
This manual page was written by Oliver Grawert ogra@ubuntu.com for the Debian system. Updated by Simon Zheng, Sun Microsystems Inc., 2008. SunOS 5.11 18 Feb 2008 gnome-power-preferences(1)
Man Page