Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

tcp_congctl(9) [netbsd man page]

TCP_CONGCTL(9)						   BSD Kernel Developer's Manual					    TCP_CONGCTL(9)

NAME
tcp_congctl -- TCP congestion control API SYNOPSIS
#include <netinet/tcp_congctl.h> int tcp_congctl_register(const char *, struct tcp_congctl *); int tcp_congctl_unregister(const char *); DESCRIPTION
The tcp_congctrl API is used to add or remove TCP congestion control algorithms on-the-fly and to modularize them. It includes basically two functions: tcp_congctl_register(const char *, struct tcp_congctl *) Registers a new congestion control algorithm. The struct tcp_congctl argument must contain a list of callbacks like the following: struct tcp_congctl { int (*fast_retransmit)(struct tcpcb *, struct tcphdr *); void (*slow_retransmit)(struct tcpcb *); void (*fast_retransmit_newack)(struct tcpcb *, struct tcphdr *); void (*newack)(struct tcpcb *, struct tcphdr *); void (*cong_exp)(struct tcpcb *); }; tcp_congctl_unregister(const char *) If found, unregister the selected TCP congestion control algorithm. RETURN VALUES
tcp_congctl_register() and tcp_congctl_unregister() both return 0 when there is no error. If the name is already registered, tcp_congctl_register() will return EEXIST. tcp_congctl_unregister() can return ENOENT if there is no congestion control algorithm by that name and can return EBUSY if the matched algorithm is being used by userspace applications. FILES
Implementation is in sys/netinet/tcp_congctl.c and the interface is in sys/netinet/tcp_congctl.h. SEE ALSO
tcp(4) BSD
October 15, 2006 BSD

Check Out this Related Man Page

CC_HD(4)						   BSD Kernel Interfaces Manual 						  CC_HD(4)

NAME
cc_hd -- HD Congestion Control Algorithm DESCRIPTION
The HD congestion control algorithm is an implementation of the Hamilton Institute's delay-based congestion control which aims to keep net- work queuing delays below a particular threshold (queue_threshold). HD probabilistically reduces the congestion window (cwnd) based on its estimate of the network queuing delay. The probability of reducing cwnd is zero at hd_qmin or less, rising to a maximum at queue_threshold, and then back to zero at the maximum queuing delay. Loss-based congestion control algorithms such as NewReno probe for network capacity by filling queues until there is a packet loss. HD com- petes with loss-based congestion control algorithms by allowing its probability of reducing cwnd to drop from a maximum at queue_threshold to be zero at the maximum queuing delay. This has been shown to work well when the bottleneck link is highly multiplexed. MIB Variables The algorithm exposes the following tunable variables in the net.inet.tcp.cc.hd branch of the sysctl(3) MIB: queue_threshold Queueing congestion threshold (qth) in ticks. Default is 20. pmax Per packet maximum backoff probability as a percentage. Default is 5. qmin Minimum queuing delay threshold (qmin) in ticks. Default is 5. SEE ALSO
cc_chd(4), cc_cubic(4), cc_htcp(4), cc_newreno(4), cc_vegas(4), h_ertt(4), mod_cc(4), tcp(4), khelp(9), mod_cc(9) L. Budzisz, R. Stanojevic, R. Shorten, and F. Baker, "A strategy for fair coexistence of loss and delay-based congestion control algorithms", IEEE Commun. Lett., 7, 13, 555-557, Jul 2009. ACKNOWLEDGEMENTS
Development and testing of this software were made possible in part by grants from the FreeBSD Foundation and Cisco University Research Pro- gram Fund at Community Foundation Silicon Valley. FUTURE WORK
The Hamilton Institute have recently made some improvements to the algorithm implemented by this module and have called it Coexistent-TCP (C- TCP). The improvements should be evaluated and potentially incorporated into this module. HISTORY
The cc_hd congestion control module first appeared in FreeBSD 9.0. The module was first released in 2010 by David Hayes whilst working on the NewTCP research project at Swinburne University of Technology's Centre for Advanced Internet Architectures, Melbourne, Australia. More details are available at: http://caia.swin.edu.au/urp/newtcp/ AUTHORS
The cc_hd congestion control module and this manual page were written by David Hayes <david.hayes@ieee.org>. BSD
September 15, 2011 BSD
Man Page