bp_copyout(9F) Kernel Functions for Drivers bp_copyout(9F)NAME
bp_copyout - copy from a driver buffer into a buf(9S)SYNOPSIS
#include <sys/types.h>
#include <sys/buf.h>
int bp_copyout(void *driverbuf, struct buf *bp, offset_t offset,
size_t size);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to the buffer header structure to copy to.
driverbuf Driver buffer to copy from.
offset Offset into bp where to start copying.
size Size of copy.
DESCRIPTION
The bp_copyout() function copies size bytes starting from the driver buffer driverbuf to offset bytes into the memory associated with bp.
The offset only applies to bp.
RETURN VALUES
Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if bp references invalid pages.
CONTEXT
The bp_copyout() function can be called from user or kernel context only.
SEE ALSO bp_copyin(9F), bp_mapin(9F), bp_mapout(9F), ddi_copyout(9F), buf(9S)SunOS 5.11 16 Oct 2007 bp_copyout(9F)
Check Out this Related Man Page
bp_mapout(9F) Kernel Functions for Drivers bp_mapout(9F)NAME
bp_mapout - deallocate virtual address space
SYNOPSIS
#include <sys/types.h>
#include <sys/buf.h>
void bp_mapout(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to the buffer header structure.
DESCRIPTION
bp_mapout() deallocates system virtual address space allocated by a previous call to bp_mapin(9F).bp_mapout() should only be called on
buffers which have been allocated and are owned by the device driver. It must not be called on buffers passed to the driver through the
strategy(9E) entry point (for example a filesystem). Because bp_mapin(9F) does not keep a reference count, bp_mapout() will wipe out any
kernel mapping that a layer above the device driver might rely on.
CONTEXT
bp_mapout() can be called from user context only.
SEE ALSO strategy(9E), bp_mapin(9F), buf(9S)
Writing Device Drivers
SunOS 5.10 15 Nov 1996 bp_mapout(9F)
Hello,
Please can someone help.
I have created a lv called lv00 in datavg
it has 8 PP's in use and each PP is 256MB
I have 537 Free PP's
Every time I copy my mksysb file to this new lv it gives me an error:
0653-447 Requested a write of ..... but wrote only ...
errpt tells me... (2 Replies)
good evening,
hi, I have problem for copy file, size more > 1 TB, just only for single file.
error said, capacity not enough, even my storage I set to 4 TB, file always reject during finish copy.
but, if I copy with multiple file/separate file, total calculation file is 2 TB, always success.... (10 Replies)