Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

scsi_get_device_type_string(9f) [opensolaris man page]

scsi_get_device_type_string(9F) 			   Kernel Functions for Drivers 			   scsi_get_device_type_string(9F)

NAME
scsi_get_device_type_string - look up per-device-type, returning matching information string SYNOPSIS
#include <sys/scsi/scsi.h> char *scsi_get_device_type_string(char *prop_name, dev_info_t *dip, struct scsi_device *devp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
prop_name Name of string array property that contains a list of paired device-type information. dip Pointer to the device info node for this HBA driver. devp Pointer to a scsi_device(9S) structure of the target. DESCRIPTION
The scsi_get_device_type_string() function looks up the prop_name property, which can be specified in the HBA's driver.conf(4)file. This property allows specification of per-device-type information. The syntax for prop_name in a driver.conf(4) file is: The formal syntax is: prop_name = <duplet> [, <duplet> *]; where: <duplet> := "<vid+pid>", "<information" The string <vid+pid> is returned by the device on a SCSI inquiry command. This string can contain any character in the range 0x20-0x7e. Characters such as double quote (") or single quote ('), which are not permitted in property value strings, are represented by their octal equivalent (for example, 42 and 47). Trailing spaces can be truncated. For example: scsi_vhci_failover_override = "STK FLEXLINE 400", "f_asym_lsi", "SUN T4", "f_tpgs";; The scsi_get_device_type_string() function searches the list of duplets for a matching INQUIRY string. If a match is found, scsi_get_device_type_string returns a copy of the <information> string. The meaning of the returned <information> string is determined by the caller. RETURN VALUES
scsi_get_device_type_string() returns a copy of the matching <information> string, or if no match is found, NULL is returned. When a non- NULL value is returned, the caller is responsible for freeing the <information> string via: kmem_free(info, strlen(info) + 1); CONTEXT
This function can be called from kernel or interrupt context. SEE ALSO
driver.conf(4) Writing Device Drivers SunOS 5.11 12 Jul 2007 scsi_get_device_type_string(9F)

Check Out this Related Man Page

scsi_get_device_type_scsi_options(9F)			   Kernel Functions for Drivers 		     scsi_get_device_type_scsi_options(9F)

NAME
scsi_get_device_type_scsi_options - look up per-device-type scsi-options property SYNOPSIS
#include <sys/scsi/scsi.h> int scsi_get_device_type_scsi_options(dev_info_t *dip, struct scsi_device *devp, int default_scsi_options); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dip Pointer to the device info node for this HBA driver. devp Pointer to a scsi_device(9S) structure of the target. default_scsi_options Value returned if no match is found. DESCRIPTION
The scsi_get_device_type_scsi_options() function looks up the property device-type-scsi-options-list, which can be specified in the HBA's driver.conf(4) file. This property allows specification of scsi-options on a per-device-type basis. The formal syntax is: device-type-scsi-options-list = <duplet> [, <duplet> *]; where: <duplet> := <vid+pid>, <scsi-options-property-name> and: <scsi-options-property-name> = <value>; The string <vid+pid> is returned by the device on a SCSI inquiry command. This string can contain any character in the range 0x20-0x7e. Characters such as double quote (") or single quote ('), which are not permitted in property value strings, are represented by their octal equivalent (for example, 42 and 47). Trailing spaces can be truncated. For example: device-type-scsi-options-list= "SEAGATE ST32550W", "seagate-options", "EXABYTE EXB-2501". "exabyte-options", "IBM OEM DFHSS4S", "ibm-options"; seagate-options = 0x78; exabyte-options = 0x58; ibm-options = 0x378; The scsi_get_device_type_scsi_options() function searches the list of duplets for a matching INQUIRY string. If a match is found, scsi_get_device_type_scsi_options() returns the corresponding value. RETURN VALUES
scsi_get_device_type_scsi_options() returns the scsi-options value found, or if no match is found the default_scsi_options value passed in. CONTEXT
This function can be called from kernel or interrupt context. SEE ALSO
Writing Device Drivers SunOS 5.10 19 Nov 2001 scsi_get_device_type_scsi_options(9F)
Man Page