VM_PAGE_IO_START(9) BSD Kernel Developer's Manual VM_PAGE_IO_START(9)NAME
vm_page_io_start, vm_page_io_finish -- ready or unready a page for I/O
SYNOPSIS
#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>
void
vm_page_io_start(vm_page_t m);
void
vm_page_io_finish(vm_page_t m);
DESCRIPTION
The vm_page_io_start() function prepares the page for I/O by incrementing its busy flag by one.
The vm_page_io_finish() function lowers the busy count on the page by one, if the resulting busy count is zero, a wakeup(9) will be issued if
the page has been marked VPO_WANTED. A page is typically marked VPO_WANTED by a thread to register its interest in the page to either com-
plete I/O or becoming available for general use.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca> and Alfred Perlstein <alfred@FreeBSD.org>.
BSD July 17, 2001 BSD
Check Out this Related Man Page
VM_PAGE_FREE(9) BSD Kernel Developer's Manual VM_PAGE_FREE(9)NAME
vm_page_free, vm_page_free_toq, vm_page_free_zero, vm_page_try_to_free -- free a page
SYNOPSIS
#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_page.h>
void
vm_page_free(vm_page_t m);
void
vm_page_free_toq(vm_page_t m);
void
vm_page_free_zero(vm_page_t m);
int
vm_page_try_to_free(vm_page_t m);
DESCRIPTION
The vm_page_free_toq() function moves a page into the free queue, and disassociates it from its object. If the page is held, wired, already
free, or its busy count is not zero, the system will panic. If the PG_ZERO flag is set on the page, it is placed at the end of the free
queue; otherwise, it is placed at the front.
If the page's object is of type OBJT_VNODE and it is the last page associated with the object, the underlying vnode may be freed.
The vm_page_free() and vm_page_free_zero() functions both call vm_page_free_toq() to actually free the page, but vm_page_free_zero() sets the
PG_ZERO flag and vm_page_free() clears the PG_ZERO flag prior to the call to vm_page_free_toq().
The vm_page_try_to_free() function verifies that the page is not held, wired, busy or dirty, and if so, marks the page as busy, drops any
protection that may be set on the page, and frees it.
RETURN VALUES
vm_page_try_to_free() returns 1 if it is able to free the page; otherwise, 0 is returned.
SEE ALSO vm_page_busy(9), vm_page_hold(9), vm_page_wire(9)AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD July 24, 2001 BSD
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)