Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

drbr(9) [freebsd man page]

DRBR(9) 						   BSD Kernel Developer's Manual						   DRBR(9)

NAME
drbr, drbr_free, drbr_enqueue, drbr_dequeue, drbr_dequeue_cond, drbr_flush, drbr_empty, drbr_inuse, -- network driver interface to buf_ring SYNOPSIS
#include <sys/param.h> #include <net/if.h> #include <net/if_var.h> void drbr_free(struct buf_ring *br, struct malloc_type *type); int drbr_enqueue(struct ifnet *ifp, struct buf_ring *br, struct mbuf *m); struct mbuf * drbr_dequeue(struct ifnet *ifp, struct buf_ring *br); struct mbuf * drbr_dequeue_cond(struct ifnet *ifp, struct buf_ring *br, int (*func) (struct mbuf *, void *), void *arg); void drbr_flush(struct ifnet *ifp, struct buf_ring *br); int drbr_empty(struct ifnet *ifp, struct buf_ring *br); int drbr_inuse(struct ifnet *ifp, struct buf_ring *br); DESCRIPTION
The drbr functions provide an API to network drivers for using buf_ring(9) for enqueueing and dequeueing packets. This is meant as a replacement for the IFQ interface for packet queuing. It allows a packet to be enqueued with a single atomic and packet dequeue to be done without any per-packet atomics as it is protected by the driver's tx queue lock. If INVARIANTS is enabled, drbr_dequeue() will assert that the tx queue lock is held when it is called. The drbr_free() function frees all the enqueued mbufs and then frees the buf_ring. The drbr_enqueue() function is used to enqueue an mbuf to a buf_ring, falling back to the ifnet's IFQ if ALTQ(4) is enabled. The drbr_dequeue() function is used to dequeue an mbuf from a buf_ring or, if ALTQ(4) is enabled, from the ifnet's IFQ. The drbr_dequeue_cond() function is used to conditionally dequeue an mbuf from a buf_ring based on whether func returns TRUE or FALSE. The drbr_flush() function frees all mbufs enqueued in the buf_ring and the ifnet's IFQ. The drbr_empty() function returns TRUE if there are no mbufs enqueued, FALSE otherwise. The drbr_inuse() function returns the number of mbufs enqueued. Note to users that this is intrinsically racy as there is no guarantee that there will not be more mbufs when drbr_dequeue() is actually called. Provided the tx queue lock is held there will not be less. RETURN VALUES
The drbr_enqueue() function returns ENOBUFS if there are no slots available in the buf_ring and 0 on success. The drbr_dequeue() and drbr_dequeue_cond() functions return an mbuf on success and NULL if the buf_ring is empty. HISTORY
These functions were introduced in FreeBSD 8.0. BSD
September 27, 2012 BSD

Check Out this Related Man Page

BUF_RING(9)						   BSD Kernel Developer's Manual					       BUF_RING(9)

NAME
buf_ring, buf_ring_alloc, buf_ring_free, buf_ring_enqueue, buf_ring_dequeue_mc, buf_ring_dequeue_sc, buf_ring_count, buf_ring_empty, buf_ring_full, buf_ring_peek, -- multi-producer, {single, multi}-consumer lock-less ring buffer SYNOPSIS
#include <sys/param.h> #include <sys/buf_ring.h> struct buf_ring * buf_ring_alloc(int count, struct malloc_type *type, int flags, struct mtx *sc_lock); void buf_ring_free(struct buf_ring *br, struct malloc_type *type); int buf_ring_enqueue(struct buf_ring *br, void *buf); void * buf_ring_dequeue_mc(struct buf_ring *br); void * buf_ring_dequeue_sc(struct buf_ring *br); int buf_ring_count(struct buf_ring *br); int buf_ring_empty(struct buf_ring *br); int buf_ring_full(struct buf_ring *br); void * buf_ring_peek(struct buf_ring *br); DESCRIPTION
The buf_ring functions provide a lock-less multi-producer and lock-less multi-consumer as well as single-consumer ring buffer. The buf_ring_alloc() function is used to allocate a buf_ring ring buffer with count slots using malloc_type type and memory flags flags. The single consumer interface is protected by sc_lock. The buf_ring_free() function is used to free a buf_ring. The user is responsible for freeing any enqueued items. The buf_ring_enqueue() function is used to enqueue a buffer to a buf_ring. The buf_ring_dequeue_mc() function is a multi-consumer safe way of dequeueing elements from a buf_ring. The buf_ring_dequeue_sc() function is a single-consumer interface to dequeue elements - requiring the user to serialize accesses with a lock. The buf_ring_count() function returns the number of elements in a buf_ring. The buf_ring_empty() function returns TRUE if the buf_ring is empty, FALSE otherwise. The buf_ring_full() function returns TRUE if no more items can be enqueued, FALSE otherwise. The buf_ring_peek() function returns a pointer to the last element in the buf_ring if the buf_ring is not empty, NULL otherwise. RETURN VALUES
The buf_ring_enqueue() function return ENOBUFS if there are no available slots in the buf_ring. HISTORY
These functions were introduced in FreeBSD 8.0. BSD
September 27, 2012 BSD
Man Page