Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

clnp(4) [netbsd man page]

CLNP(4) 						   BSD Kernel Interfaces Manual 						   CLNP(4)

NAME
clnp -- Connectionless-Mode Network Protocol SYNOPSIS
#include <sys/socket.h> #include <netiso/iso.h> #include <netiso/clnp.h> int socket(AF_ISO, SOCK_RAW, 0); DESCRIPTION
CLNP is the connectionless-mode network protocol used by the connectionless-mode network service. This protocol is specified in ISO 8473. It may be accessed through a ``raw socket'' for debugging purposes only. CLNP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) system calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the read(2) or recv(2) and write(2) or send(2) system calls may be used). Outgoing packets automatically have a CLNP header prepended to them. Incoming packets received by the user contain the full CLNP header. The following setsockopt(2) options apply to CLNP: CLNPOPT_FLAGS Sets the flags which are passed to clnp when sending a datagram. Valid flags are: CLNP_NO_SEG Do not allow segmentation CLNP_NO_ER Suppress ER pdus CLNP_NO_CKSUM Do not generate the CLNP checksum CLNPOPT_OPTS Sets CLNP options. The options must be formatted exactly as specified by ISO 8473, section 7.5 ``Options Part''. Once an option has been set, it will be sent on all packets until a different option is set. CONGESTION EXPERIENCE BIT
Whenever a packet is transmitted, the globally unique quality of service option is added to the packet. The sequencing preferred bit and the low transit delay bit are set in this option. If a packet is forwarded containing the globally unique quality of service option, and the interface through which the packet will be trans- mitted has a queue length greater than congest_threshold, then the congestion experienced bit is set in the quality of service option. The threshold value stored in congest_threshold may be tuned. When a packet is received with the globally unique quality of service option present, and the congestion experienced bit is set, then the transport congestion control function is called. DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] When trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina- tion address specified and the socket is already connected; [ENOTCONN] When trying to send a datagram, but no destination address is specified, and the socket hasn't been connected; [ENOBUFS] When the system runs out of memory for an internal data structure; [EADDRNOTAVAIL] When an attempt is made to create a socket with a network address for which no network interface exists; [EHOSTUNREACH] When trying to send a datagram, but no route to the destination address exists. [EINVAL] When specifying unsupported options. SEE ALSO
recv(2), send(2), intro(4), iso(4) BUGS
Packets are sent with the type code of 0x1d (technically an invalid packet type) for lack of a better way to identify raw CLNP packets. No more than MLEN bytes of options can be specified. BSD
April 2, 1994 BSD

Check Out this Related Man Page

ICMP(4) 						   BSD Kernel Interfaces Manual 						   ICMP(4)

NAME
icmp -- Internet Control Message Protocol SYNOPSIS
#include <sys/socket.h> #include <netinet/in.h> int socket(AF_INET, SOCK_RAW, proto); DESCRIPTION
ICMP is the error and control message protocol used by IP and the Internet protocol family. It may be accessed through a ``raw socket'' for network monitoring and diagnostic functions. The proto parameter to the socket call to create an ICMP socket is obtained from getprotobyname(3). ICMP sockets are connectionless, and are normally used with the sendto and recvfrom calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the read(2) or recv(2) and write(2) or send(2) system calls may be used). Outgoing packets automatically have an IP header prepended to them (based on the destination address). Incoming packets are received with the IP header and options intact. Non-privileged ICMP ICMP sockets can be opened with the SOCK_DGRAM socket type without requiring root privileges. The synopsis is the following: socket(AF_INET, SOCK_DGRAM, IPPROTO_ICMP) This can be used by non root privileged processes to send ICMP echo requests to gauge the quality of the connectivity to a host, to receive ICMP destination unreachable message for path MTU discovery, or to receveive time exceeded message for traceroute. Datagram oriented ICMP sockets offer a subset of the functionality available to raw ICMP sockets. Only IMCP request messages of the following types can be sent: ICMP_ECHO, ICMP_TSTAMP or ICMP_MASKREQ. The code field must be the value zero (0). The minimal length of an ICMP message request is eight (8) octets. The following IP level option can be used with datagram oriented ICMP sockets: IP_OPTIONS IP_HDRINCL IP_TOS IP_TTL IP_RECVOPTS IP_RECVRETOPTS IP_RECVDSTADDR IP_RETOPTS IP_MULTICAST_IF IP_MULTICAST_TTL IP_MULTICAST_LOOP IP_ADD_MEMBERSHIP IP_DROP_MEMBERSHIP IP_MULTICAST_VIF IP_PORTRANGE IP_RECVIF IP_IPSEC_POLICY IP_STRIPHDR When the IP option IP_HDRINCL is used, the provided IP header must obey the following rules: ip_v Must be IPVERSION (4); ip_hl Between 5 and 10 (inclusive); ip_tos Any value; ip_len Must be the total length of IP datagram (IP header + ICMP message); ip_id Must be zero, will be automatically set; ip_off Must be zero, will be automatically set; ip_ttl Any value; ip_p Must be IPPROTO_IP; ip_sum Value ignored, will be automatically set; ip_src Must be an IP address currently assigned to one of the local interface or INADDR_ANY; ip_dst Any address; ip_opts Any option. The maximum length of a IMCP message that can be sent is controlled by the sysctl variable net.inet.raw.maxdgram. DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina- tion address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been connected; [ENOBUFS] when the system runs out of memory for an internal data structure; [EADDRNOTAVAIL] when an attempt is made to create a socket with a network address for which no network interface exists; [EINVAL] when an invalid value is used with IMCP datagram socket for a field of the IP or ICMP header. SEE ALSO
send(2), recv(2), intro(4), inet(4), ip(4) HISTORY
The icmp protocol appeared in 4.3BSD. 4.3 Berkeley Distribution June 19, 2002 4.3 Berkeley Distribution
Man Page