Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

iso(4) [netbsd man page]

ISO(4)							   BSD Kernel Interfaces Manual 						    ISO(4)

NAME
iso -- ISO protocol family SYNOPSIS
#include <sys/types.h> #include <netiso/iso.h> DESCRIPTION
The ISO protocol family is a collection of protocols that uses the ISO address format. The ISO family provides protocol support for the SOCK_SEQPACKET abstraction through the TP protocol (ISO 8073), for the SOCK_DGRAM abstraction through the connectionless transport protocol (ISO 8602), and for the SOCK_RAW abstraction by providing direct access (for debugging) to the CLNP (ISO 8473) network layer protocol. ADDRESSING
ISO addresses are based upon ISO 8348/AD2, Addendum to the Network Service Definition Covering Network Layer Addressing. Sockets bound to the OSI protocol family use the following address structure: struct iso_addr { u_char isoa_len; /* length, not including this byte */ char isoa_genaddr[20]; /* general opaque address */ }; struct sockaddr_iso { u_char siso_len; /* size of this sockaddr */ sa_family_t siso_family; /* addressing domain, AF_ISO */ u_char siso_plen; /* presentation selector length */ u_char siso_slen; /* session selector length */ u_char siso_tlen; /* transport selector length */ struct iso_addr siso_addr; /* network address */ u_char siso_pad[6]; /* space for gosip v2 SELs */ }; #define siso_nlen siso_addr.isoa_len #define siso_data siso_addr.isoa_genaddr The fields of this structure are: siso_len: Length of the entire address structure, in bytes, which may grow to be longer than the 32 bytes shown above. siso_family: Identifies the domain: AF_ISO. siso_tlen: Length of the transport selector. siso_slen: Length of the session selector. This is not currently supported by the kernel and is provided as a convenience for user level pro- grams. siso_plen: Length of the presentation selector. This is not currently supported by the kernel and is provided as a convenience for user level programs. siso_addr: The network part of the address, described below. TRANSPORT ADDRESSING
An ISO transport address is similar to an Internet address in that it contains a network-address portion and a portion that the transport layer uses to multiplex its services among clients. In the Internet domain, this portion of the address is called a port. In the ISO domain, this is called a transport selector (also known at one time as a transport suffix). While ports are always 16 bits, transport selec- tors may be of (almost) arbitrary size. Since the C language does not provide convenient variable length structures, we have separated the selector lengths from the data themselves. The network address and various selectors are stored contiguously, with the network address first, then the transport selector, and so on. Thus, if you had a network address of less than 20 bytes, the transport selector would encroach on space normally reserved for the network address. NETWORK ADDRESSING
ISO network addresses are limited to 20 bytes in length. ISO network addresses can take any format. PROTOCOLS
The ARGO 1.0 implementation of the ISO protocol family comprises the Connectionless-Mode Network Protocol (CLNP), and the Transport Protocol (TP), classes 4 and 0, and X.25. TP is used to support the SOCK_SEQPACKET abstraction. A raw interface to CLNP is available by creating an ISO socket of type SOCK_RAW. This is used for CLNP debugging only. SEE ALSO
clnp(4), cltp(4), tp(4) BSD
November 30, 1993 BSD

Check Out this Related Man Page

CLNP(4) 						   BSD Kernel Interfaces Manual 						   CLNP(4)

NAME
clnp -- Connectionless-Mode Network Protocol SYNOPSIS
#include <sys/socket.h> #include <netiso/iso.h> #include <netiso/clnp.h> int socket(AF_ISO, SOCK_RAW, 0); DESCRIPTION
CLNP is the connectionless-mode network protocol used by the connectionless-mode network service. This protocol is specified in ISO 8473. It may be accessed through a ``raw socket'' for debugging purposes only. CLNP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) system calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the read(2) or recv(2) and write(2) or send(2) system calls may be used). Outgoing packets automatically have a CLNP header prepended to them. Incoming packets received by the user contain the full CLNP header. The following setsockopt(2) options apply to CLNP: CLNPOPT_FLAGS Sets the flags which are passed to clnp when sending a datagram. Valid flags are: CLNP_NO_SEG Do not allow segmentation CLNP_NO_ER Suppress ER pdus CLNP_NO_CKSUM Do not generate the CLNP checksum CLNPOPT_OPTS Sets CLNP options. The options must be formatted exactly as specified by ISO 8473, section 7.5 ``Options Part''. Once an option has been set, it will be sent on all packets until a different option is set. CONGESTION EXPERIENCE BIT
Whenever a packet is transmitted, the globally unique quality of service option is added to the packet. The sequencing preferred bit and the low transit delay bit are set in this option. If a packet is forwarded containing the globally unique quality of service option, and the interface through which the packet will be trans- mitted has a queue length greater than congest_threshold, then the congestion experienced bit is set in the quality of service option. The threshold value stored in congest_threshold may be tuned. When a packet is received with the globally unique quality of service option present, and the congestion experienced bit is set, then the transport congestion control function is called. DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] When trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina- tion address specified and the socket is already connected; [ENOTCONN] When trying to send a datagram, but no destination address is specified, and the socket hasn't been connected; [ENOBUFS] When the system runs out of memory for an internal data structure; [EADDRNOTAVAIL] When an attempt is made to create a socket with a network address for which no network interface exists; [EHOSTUNREACH] When trying to send a datagram, but no route to the destination address exists. [EINVAL] When specifying unsupported options. SEE ALSO
recv(2), send(2), intro(4), iso(4) BUGS
Packets are sent with the type code of 0x1d (technically an invalid packet type) for lack of a better way to identify raw CLNP packets. No more than MLEN bytes of options can be specified. BSD
April 2, 1994 BSD
Man Page