Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ppsratecheck(9) [netbsd man page]

PPSRATECHECK(9) 					   BSD Kernel Developer's Manual					   PPSRATECHECK(9)

NAME
ppsratecheck -- function to help implement rate-limited actions SYNOPSIS
#include <sys/time.h> int ppsratecheck(struct timeval *lasttime, int *curpps, int maxpps); DESCRIPTION
The ppsratecheck() function provides easy way to perform packet-per-sec, or event-per-sec, rate limitation. The motivation for implementing ppsratecheck() was to provide a mechanism that could be used to add rate limitation to network packet output. For certain network packets, we may want to impose rate limitation, to avoid denial-of-service attack possibilities. maxpps specifies maximum permitted packets, or events, per second. If ppsratecheck() is called more than maxpps times in a given one second period, the function will return 0, indicating that we exceeded the limit. If we are below the limit, the function will return 1. If maxpps is set to 0, the function will always return 0 (no packets/events are permitted). Negative maxpps indicates that rate limitation is dis- abled, and ppsratecheck will always return 1. curpps and lasttime are used to maintain the number of recent calls. curpps will be incremented every time ppsratecheck() is called, and will be reset whenever necessary. SEE ALSO
log(9), printf(9), ratecheck(9), time_second(9) HISTORY
The ppsratecheck() function appeared in NetBSD 1.5. BSD
August 3, 2000 BSD

Check Out this Related Man Page

FQ(8)								       Linux								     FQ(8)

NAME
FQ - Fair Queue traffic policing SYNOPSIS
tc qdisc ... fq [ limit PACKETS ] [ flow_limit PACKETS ] [ quantum BYTES ] [ initial_quantum BYTES ] [ maxrate RATE ] [ buckets NUMBER ] [ pacing | nopacing ] DESCRIPTION
FQ (Fair Queue) is a classless packet scheduler meant to be mostly used for locally generated traffic. It is designed to achieve per flow pacing. FQ does flow separation, and is able to respect pacing requirements set by TCP stack. All packets belonging to a socket are con- sidered as a 'flow'. For non local packets (router workload), packet rxhash is used as fallback. An application can specify a maximum pacing rate using the SO_MAX_PACING_RATE setsockopt call. This packet scheduler adds delay between packets to respect rate limitation set by TCP stack. Dequeueing happens in a round-robin fashion. A special FIFO queue is reserved for high priority packets ( TC_PRIO_CONTROL priority), such packets are always dequeued first. FQ is non-work-conserving. TCP pacing is good for flows having idle times, as the congestion window permits TCP stack to queue a possibly large number of packets. This removes the 'slow start after idle' choice, badly hitting large BDP flows and applications delivering chunks of data such as video streams. PARAMETERS
limit Hard limit on the real queue size. When this limit is reached, new packets are dropped. If the value is lowered, packets are dropped so that the new limit is met. Default is 10000 packets. flow_limit Hard limit on the maximum number of packets queued per flow. Default value is 100. quantum The credit per dequeue RR round, i.e. the amount of bytes a flow is allowed to dequeue at once. A larger value means a longer time period before the next flow will be served. Default is 2 * interface MTU bytes. initial_quantum The initial sending rate credit, i.e. the amount of bytes a new flow is allowed to dequeue initially. This is specifically meant to allow using IW10 without added delay. Default is 10 * interface MTU, i.e. 15140 for 'standard' ethernet. maxrate Maximum sending rate of a flow. Default is unlimited. Application specific setting via SO_MAX_PACING_RATE is ignored only if it is larger than this value. buckets The size of the hash table used for flow lookups. Each bucket is assigned a red-black tree for efficient collision sorting. Default: 1024. [no]pacing Enable or disable flow pacing. Default is enabled. EXAMPLES
#tc qdisc add dev eth0 root fq #tc -s -d qdisc qdisc fq 8003: dev eth0 root refcnt 2 limit 10000p flow_limit 100p buckets 1024 quantum 3028 initial_quantum 15140 Sent 503727981 bytes 1146972 pkt (dropped 0, overlimits 0 requeues 54452) backlog 0b 0p requeues 54452 1289 flows (1289 inactive, 0 throttled) 0 gc, 31 highprio, 27411 throttled SEE ALSO
tc(8), socket(7) AUTHORS
FQ was written by Eric Dumazet. iproute2 10 Sept 2015 FQ(8)
Man Page