Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ratecheck(9) [netbsd man page]

RATECHECK(9)						   BSD Kernel Developer's Manual					      RATECHECK(9)

NAME
ratecheck -- function to help implement rate-limited actions SYNOPSIS
#include <sys/time.h> int ratecheck(struct timeval *lasttime, const struct timeval *mininterval); DESCRIPTION
The ratecheck() function provides a simple time interval check which can be used when implementing time-based rate-limited actions. If the difference between the current monotonically-increasing system time (mono_time) and lasttime is less than the value given by the mininterval argument, zero is returned. Otherwise, lasttime is set to the current time and a non-zero value is returned. The motivation for implementing ratecheck() was to provide a mechanism that could be used to add rate limiting to diagnostic message output. If printed too often, diagnostic messages can keep the system from doing useful work. If the repeated messages can be caused by deliberate user action or network events, they can be exploited to cause denial of system service. Note that using a very short time interval (less than a second) for mininterval defeats the purpose of this function. (It doesn't take much to flood a 9600 baud serial console with output, for instance.) EXAMPLES
Here is a simple example of use of the ratecheck() function: /* * The following variables could be global, in a device softc, etc., * depending on the exact usage. */ struct timeval drv_lasterr1time; /* time of last err1 message */ long drv_err1count; /* # of err1 errs since last msg */ struct timeval drv_lasterr2time; /* time of last err2 message */ long drv_err2count; /* # of err2 errs since last msg */ /* * The following variable will often be global or shared by all * instances of a driver. It should be initialized, so it can be * patched. Allowing it to be set via an option might be nice, * but could lead to an insane proliferation of options. */ struct timeval drv_errintvl = { 5, 0 }; /* 5 seconds */ /* error handling/reporting function */ void drv_errhandler(int err1, int err2) { /* * Note that you should NOT use the same last-event * time variable for dissimilar messages! */ if (err1) { /* handle err1 condition */ ... drv_err1count++; if (ratecheck(&drv_lasterr1notice, &drv_errinterval)) { printf("drv: %ld err1 errors occurred", drv_err1count); drv_err1count = 0; } } if (err2) { /* handle err2 condition */ ... drv_err2count++; if (ratecheck(&drv_lasterr2notice, &drv_errinterval)) { printf("drv: %ld err2 errors occurred", drv_err2count); drv_err2count = 0; } } } SEE ALSO
log(9), ppsratecheck(9), printf(9), time_second(9) HISTORY
The ratecheck() function appeared in NetBSD 1.5. BUGS
ratecheck() may not work as expected, if mininterval is less than the hardware clock interrupt interval (1/hz). BSD
February 2, 2000 BSD

Check Out this Related Man Page

TIMERADD(3)						   BSD Library Functions Manual 					       TIMERADD(3)

NAME
timeradd -- operations on time structure SYNOPSIS
#include <sys/time.h> void timeradd(struct timeval *a, struct timeval *b, struct timeval *res); void timersub(struct timeval *a, struct timeval *b, struct timeval *res); void timerclear(struct timeval *tv); int timerisset(struct timeval *tv); int timercmp(struct timeval *a, struct timeval *b, CMP); void timespecadd(struct timespec *a, struct timespec *b, struct timespec *res); void timespecsub(struct timespec *a, struct timespec *b, struct timespec *res); void timespecclear(struct timespec *ts); int timespecisset(struct timespec *ts); int timespeccmp(struct timespec *a, struct timespec b, CMP); DESCRIPTION
These macros are provided for manipulating the timeval and timespec structures described in timeval(3). The timeradd() and timespecadd() macros add the time information stored in a to b, storing the result in res. With timeradd() the results are simplified such that the value of res->tv_usec is always less than 1,000,000 (1 second). With timespecadd() the res->tv_nsec member of struct timespec is always less than 1,000,000,000. The timersub() and timespecsub() macros subtract the time information stored in b from a and store the resulting structure in res. The timerclear() and timespecclear() macros initialize the structures to midnight (0 hour) January 1st, 1970 (the Epoch). In other words, they set the members of the structure to zero. The timerisset() and timespecisset() macros return true if the input structure is set to any time value other than the Epoch. The timercmp() and timespeccmp() macros compare a to b using the comparison operator given in CMP. The result of the comparison is returned. SEE ALSO
timeval(3) HISTORY
The timeradd() family of macros first appeared in NetBSD 1.1. These were later ported to FreeBSD 2.2.6. The timespec() family of macros first appeared in NetBSD 1.2. BSD
June 7, 2010 BSD
Man Page