Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

quotactl(7i) [opensolaris man page]

quotactl(7I)							  Ioctl Requests						      quotactl(7I)

NAME
quotactl - manipulate disk quotas SYNOPSIS
#include <sys/fs/ufs_quota.h> int ioctl(int fd, Q_QUOTACTL, struct quotcl *qp) DESCRIPTION
This ioctl() call manipulates disk quotas. fd is the file descriptor returned by the open() system call after opening the quotas file (located in the root directory of the filesystem running quotas.) Q_QUOTACTL is defined in /usr/include/sys/fs/ufs_quota.h. qp is the address of the quotctl structure which is defined as struct quotctl { int op; uid_t uid; caddr_t addr; }; op indicates an operation to be applied to the user ID uid. (See below.) addr is the address of an optional, command specific, data struc- ture which is copied in or out of the system. The interpretation of addr is given with each value of op below. Q_QUOTAON Turn on quotas for a file system. addr points to the full pathname of the quotas file. uid is ignored. It is recommended that uid have the value of 0. This call is restricted to the super-user. Q_QUOTAOFF Turn off quotas for a file system. addr and uid are ignored. It is recommended that addr have the value of NULL and uid have the value of 0. This call is restricted to the super-user. Q_GETQUOTA Get disk quota limits and current usage for user uid. addr is a pointer to a dqblk structure (defined in <sys/fs/ufs_quota.h>). Only the super-user may get the quotas of a user other than himself. Q_SETQUOTA Set disk quota limits and current usage for user uid. addr is a pointer to a dqblk structure (defined in sys/fs/ufs_quota.h). This call is restricted to the super-user. Q_SETQLIM Set disk quota limits for user uid. addr is a pointer to a dqblk structure (defined in sys/fs/ufs_quota.h). This call is restricted to the super-user. Q_SYNC Update the on-disk copy of quota usages for this file system. addr and uid are ignored. Q_ALLSYNC Update the on-disk copy of quota usages for all file systems with active quotas. addr and uid are ignored. RETURN VALUES
This ioctl() returns: 0 on success. -1 on failure and sets errno to indicate the error. ERRORS
EFAULT addr is invalid. EINVAL The kernel has not been compiled with the QUOTA option. op is invalid. ENOENT The quotas file specified by addr does not exist. EPERM The call is privileged and the calling process did not assert {PRIV_SYS_MOUNT} in the effective set. ESRCH No disk quota is found for the indicated user. Quotas have not been turned on for this file system. EUSERS The quota table is full. If op is Q_QUOTAON, ioctl() may set errno to: EACCES The quota file pointed to by addr exists but is not a regular file. The quota file pointed to by addr exists but is not on the file system pointed to by special. EIO Internal I/O error while attempting to read the quotas file pointed to by addr. FILES
/usr/include/sys/fs/ufs_quota.h quota-related structure/function definitions and defines SEE ALSO
quota(1M), quotacheck(1M), quotaon(1M), getrlimit(2), mount(2) BUGS
There should be some way to integrate this call with the resource limit interface provided by setrlimit() and getrlimit(2). This call is incompatible with Melbourne quotas. SunOS 5.11 14 June 2004 quotactl(7I)

Check Out this Related Man Page

quota(2)							System Calls Manual							  quota(2)

Name
       quota - manipulate disk quotas

Syntax
       #include <sys/types.h>
       #include <sys/param.h>
       #include <sys/quota.h>

       quota(cmd, uid, arg, addr)
       int cmd, uid, arg;
       caddr_t addr;

Description
       The  call manipulates disk quotas for file systems that have had quotas enabled with The cmd parameter indicates a command in the following
       list that is applied to the user ID uid.  The arg parameter is a command specific argument and addr is the address of an optional,  command
       specific  data  structure,  which  is copied in or out of the system.  The interpretation of arg and addr is given with each command in the
       list that follows:

       Q_SETDLIM
	      Set disk quota limits and current usage for the user with ID uid.  The arg parameter is a major-minor device indicating a particular
	      file  system.   The addr parameter is a pointer to a struct dqblk structure, defined in <sys/quota.h>.  Only the superuser can issue
	      this call.

       Q_GETDLIM
	      Get disk quota limits and current use for the user with ID uid.  The remaining parameters are identical  to  the	Q_SETDLIM  command
	      parameters.

       Q_SETDUSE
	      Set  disk  use limits for the user with ID uid.  The arg parameter is a major-minor device indicating a particular file system.  The
	      addr is a pointer to a struct dqusage structure, defined in <sys/quota.h>.  Only the superuser can issue this call.

       Q_SYNC Update the on-disk copy of quota uses.  The uid, arg, and addr parameters are ignored.

       Q_SETUID
	      Change the calling process's quota limits to those of the user with ID uid.  The arg and addr  parameters  are  ignored.	 Only  the
	      superuser can issue this call.

       Q_SETWARN
	      Alter  the disk usage warning limits for the user with ID uid.  The arg is a major-minor device indicating a particular file system.
	      The addr parameter is a pointer to a struct dqwarn structure, which is defined in <sys/quota.h>.	Only the superuse can  issue  this
	      call.

       Q_DOWARN
	      Warn  the user with user ID uid about excessive disk use.  This call causes the system to check its current disk use information and
	      print a message on the terminal of the caller for each file system on which the user is over quota.  If the arg parameter is  speci-
	      fied  as	NODEV,	all  file systems that have disk quotas are checked.  Otherwise, arg indicates a specific major-minor device to be
	      checked.	Only the superuser can issue this call.

Return Values
       A successful call returns 0 and, possibly, more information specific to the command specified in the cmd parameter; when an  error  occurs,
       the value -1 is returned and the global variable errno is set to indicate the reason.

Diagnostics
       A quota call fails when one of the following occurs:

       [EINVAL]       The kernel has not been compiled with the QUOTA option.

       [EINVAL]       The cmd parameter is invalid.

       [ESRCH]	      No disk quota is found for the indicated user.

       [EPERM]	      Only the superuser can issue the call and the caller is not the superuser.

       [ENODEV]       The arg parameter is being interpreted as a major-minor device, and it indicates an unmounted file system.

       [EFAULT]       An invalid addr parameter is supplied; the associated structure could not be copied in or out of the kernel.

       [EUSERS]       The quota table is full.

See Also
       "Disk Quotas in a UNIX Environment", ULTRIX Supplementary Documents, Volume 3:System Manager

																	  quota(2)
Man Page