Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_enter_critical(9f) [sunos man page]

ddi_enter_critical(9F)					   Kernel Functions for Drivers 				    ddi_enter_critical(9F)

NAME
ddi_enter_critical, ddi_exit_critical - enter and exit a critical region of control SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> unsigned int ddi_enter_critical(void); void ddi_exit_critical(unsignedint ddic); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ddic The returned value from the call to ddi_enter_critical() must be passed to ddi_exit_critical(). DESCRIPTION
Nearly all driver operations can be done without any special synchronization and protection mechanisms beyond those provided by, for exam- ple, mutexes (see mutex(9F)). However, for certain devices there can exist a very short critical region of code which must be allowed to run uninterrupted. The function ddi_enter_critical() provides a mechanism by which a driver can ask the system to guarantee to the best of its ability that the current thread of execution will neither be preempted nor interrupted. This stays in effect until a bracketing call to ddi_exit_critical() is made (with an argument which was the returned value from ddi_enter_critical()). The driver may not call any functions external to itself in between the time it calls ddi_enter_critical() and the time it calls ddi_exit_critical(). RETURN VALUES
ddi_enter_critical() returns an opaque unsigned integer which must be used in the subsequent call to ddi_exit_critical(). CONTEXT
This function can be called from user or interrupt context. WARNINGS
Driver writers should note that in a multiple processor system this function does not temporarily suspend other processors from executing. This function also cannot guarantee to actually block the hardware from doing such things as interrupt acknowledge cycles. What it can do is guarantee that the currently executing thread will not be preempted. Do not write code bracketed by ddi_enter_critical() and ddi_exit_critical() that can get caught in an infinite loop, as the machine may crash if you do. SEE ALSO
mutex(9F) Writing Device Drivers SunOS 5.10 4 Nov 1991 ddi_enter_critical(9F)

Check Out this Related Man Page

ddi_intr_hilevel(9F)					   Kernel Functions for Drivers 				      ddi_intr_hilevel(9F)

NAME
ddi_intr_hilevel - indicate interrupt handler type SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_intr_hilevel(dev_info_t *dip, uint_t inumber); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This interface is obsolete. Use the new interrupt interfaces referenced in Intro(9F). Refer to Writing Device Drivers for more information. PARAMETERS
dip Pointer to dev_info structure. inumber Interrupt number. DESCRIPTION
The ddi_intr_hilevel() function returns non-zero if the specified interrupt is a "high level" interrupt. High level interrupts must be handled without using system services that manipulate thread or process states, because these interrupts are not blocked by the scheduler. In addition, high level interrupt handlers must take care to do a minimum of work because they are not preemptable. A typical high level interrupt handler would put data into a circular buffer and schedule a soft interrupt by calling ddi_trigger_soft- intr(). The circular buffer could be protected by using a mutex that was properly initialized for the interrupt handler. The ddi_intr_hilevel() function can be used before calling ddi_add_intr() to decide which type of interrupt handler should be used. Most device drivers are designed with the knowledge that the devices they support will always generate low level interrupts, however some devices, for example those using SBus or VME bus level 6 or 7 interrupts must use this test because on some machines those interrupts are high level (above the scheduler level) and on other machines they are not. RETURN VALUES
non-zero indicates a high-level interrupt. CONTEXT
These functions can be called from useruser, interrupt, or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
ddi_add_intr(9F), Intro(9F), mutex(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_intr_hilevel(9F)
Man Page