ddi_exit_critical(9f) [sunos man page]
ddi_enter_critical(9F) Kernel Functions for Drivers ddi_enter_critical(9F) NAME
ddi_enter_critical, ddi_exit_critical - enter and exit a critical region of control SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> unsigned int ddi_enter_critical(void); void ddi_exit_critical(unsignedint ddic); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ddic The returned value from the call to ddi_enter_critical() must be passed to ddi_exit_critical(). DESCRIPTION
Nearly all driver operations can be done without any special synchronization and protection mechanisms beyond those provided by, for exam- ple, mutexes (see mutex(9F)). However, for certain devices there can exist a very short critical region of code which must be allowed to run uninterrupted. The function ddi_enter_critical() provides a mechanism by which a driver can ask the system to guarantee to the best of its ability that the current thread of execution will neither be preempted nor interrupted. This stays in effect until a bracketing call to ddi_exit_critical() is made (with an argument which was the returned value from ddi_enter_critical()). The driver may not call any functions external to itself in between the time it calls ddi_enter_critical() and the time it calls ddi_exit_critical(). RETURN VALUES
ddi_enter_critical() returns an opaque unsigned integer which must be used in the subsequent call to ddi_exit_critical(). CONTEXT
This function can be called from user or interrupt context. WARNINGS
Driver writers should note that in a multiple processor system this function does not temporarily suspend other processors from executing. This function also cannot guarantee to actually block the hardware from doing such things as interrupt acknowledge cycles. What it can do is guarantee that the currently executing thread will not be preempted. Do not write code bracketed by ddi_enter_critical() and ddi_exit_critical() that can get caught in an infinite loop, as the machine may crash if you do. SEE ALSO
mutex(9F) Writing Device Drivers SunOS 5.10 4 Nov 1991 ddi_enter_critical(9F)
Check Out this Related Man Page
ddi_intr_get_supported_types(9F) Kernel Functions for Drivers ddi_intr_get_supported_types(9F) NAME
ddi_intr_get_supported_types - return information on supported hardware interrupt types SYNOPSIS
#include <sys/types.h> #include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_intr_get_supported_types(dev_info_t *dip, int *typesp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to dev_info structure typesp Pointer to supported interrupt types DESCRIPTION
The ddi_intr_get_supported_types() function retrieves the interrupt types supported by a particular hardware device and by the system soft- ware. Upon successful return, the supported types are returned as a bit mask in the integer pointed to by the typesp argument. See <sys/ddi_intr.h> for a list of interrupts that can be returned by a hardware device. For PCI devices that support MSI and/or MSI-X based hardware, this interface returns only the interrupt types that are supported by all the hardware in the path to the hardware device. An interrupt type is usable by the hardware device if it is returned by the ddi_intr_get_supported_types() function. The device driver can be programmed to use one of the returned interrupt types to receive hardware interrupts. RETURN VALUES
The ddi_intr_get_supported_types() function returns: DDI_SUCCESS On success. DDI_EINVAL On encountering invalid input parameters. DDI_INTR_NOTFOUND Returned when the hardware device is found not to support any hardware interrupts. CONTEXT
The ddi_intr_get_supported_types() function can be called from user or kernel non-interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
pci(4), attributes(5), pcmcia(7D), sysbus(4), ddi_intr_add_handler(9F), ddi_intr_alloc(9F), ddi_intr_enable(9F) Writing Device Drivers NOTES
The ddi_intr_get_supported_types() function can be called by the device driver even at any time if the driver has added an interrupt han- dler for a given interrupt type. Soft interrupts are always usable and are not returned by this interface. Any consumer of this interface should verify that the return value is not equal to DDI_SUCCESS. Incomplete checking for failure codes could result in inconsistent behavior among platforms. SunOS 5.11 07 Apr 2005 ddi_intr_get_supported_types(9F)